Closed Bug 1302674 Opened 3 years ago Closed 3 years ago

plain text format-flowed mail: when replying quoted text is not flowed.

Categories

(Thunderbird :: Untriaged, defect)

45 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 456053

People

(Reporter: miguel.negrao, Unassigned)

Details

Attachments

(6 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160802213348

Steps to reproduce:

Reply to a format=flowed plain text email, with also my settings set to always send with format=flowed. 


Actual results:

Quoted text is not flowed (doesn't adapt to window size) neither on the editing window when composing reply email, neither when viewed as the received message, neither when viewed as received message in other mail programs such as geary.


Expected results:

The quoted text should flow. 

I'm not exactly sure how technically that should be achieved. Apple mail, iphone mail and geary are all able to flow quoted text (that they themselves have quoted) by doing: 

Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: quoted-printable

...

> 1 test testtesttest test testtesttest test testtesttest test=20
> testtesttest test testtesttest test testtesttest test testtesttest=20
> test testtesttest test testtesttest test testtesttest testEND.


Thunderbirds quoted text is not flowed because it encodes it like so:

Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit

...

> 1 test testtesttest test testtesttest test testtesttest test
> testtesttest test testtesttest test testtesttest test testtesttest test
> testtesttest test testtesttest test testtesttest testEND.
original email
Attachment #8791124 - Attachment description: thunderbird_1.eml → thunderbird_1.eml - original email
Attachment #8791123 - Attachment description: thunderbird_2.eml → thunderbird_2.eml - reply and quote from thunderbird
Attached image quote_thunder.png
Attached image geary_reply.png
Thanks for filing this bug report. Yes, that's an old (and very annoying) issue, unfortunately didn't get any attention for a long time. The fix likely requires a core change in the code shared with other applications like Firefox, which isn't helping either.

Marking as a duplicate to keep the discussion at a single place.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456053
You need to log in before you can comment on or make changes to this bug.