The role="presentation" attribute in tables is not inherited by table rows/cells

RESOLVED INVALID

Status

()

Core
Disability Access APIs
P3
normal
RESOLVED INVALID
a year ago
5 months ago

People

(Reporter: Alessandro, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8791190 [details]
2016-09-14_1625.png

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36

Steps to reproduce:

I have create a table with role="presentation" attribute at the root level:

    <table role="presentation">
        <tr>
            <td>
                1
            </td>
            <td>
                2
            </td>
        </tr>
        <tr>
            <td>
                3
            </td>
            <td>
                4
            </td>
        </tr>
    </table>


Actual results:

Accessibility Tree in DOM Inspector displays table cells as shown in the attached screenshot.


Expected results:

Accessibility Tree should not contain table cells because the parent table element is marked with the role="presentation" attribute.
(Reporter)

Comment 1

a year ago
Forgot to mention that the same issue is replicated in the context of lists. For example:

    <ul role="presentation">
        <li>One</li>
        <li>Two</li>
        <li>Three</li>
    </ul>

If you inspect Accessibility Tree of this markup, you will see LI text containers.

Updated

a year ago
Component: Untriaged → Layout: Tables
Product: Firefox → Core
(Reporter)

Updated

a year ago
Component: Layout: Tables → Disability Access APIs

Comment 2

5 months ago
Those are text containers and I think we have to expose them to not get the text jammed. Please reopen if you disagree.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Priority: -- → P3
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.