Closed Bug 1302770 Opened 3 years ago Closed 3 years ago

Old bookmark becoming invalid, when I add a new one with a conflicting keyword

Categories

(Toolkit :: Places, defect, major)

defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dqeswn, Unassigned)

References

Details

If you set a conflicting keyword, the old bookmark becomes an invalid bookmark somehow.

The properties windows doesn't show anything, but an "order by name" checkbox which doesn't even belong there. On hover either nothing is shown or the previously hovered bookmarks's url. Left click, middle click does nothing, deleting doesn't work.

At first I was happy to see the when I used a keyword that was already used, it was deleted from the old bookmark. So it didn't happen immediately, but now all of those bookmarks are broken.
Blocks: 1150678
Are there any JS errors listed in the browser console?
CC'ing Marco who's aware of bookmarks and places file.
I will try to reproduce, though I may need your places.sqlite (privately) or you to run some queries on it for me, if you don't want to share it.
Flags: needinfo?(mak77)
(In reply to Henrik Skupin (:whimboo) from comment #1)
> Are there any JS errors listed in the browser console?

If they were they're gone now. At first the bookmarks were alright, so I didn't look at errors. I'm sure of this because I looked at them to remove the old hotkey, but they were removed automatically. (Conflicting hotkeys could coexist before 1150678)
I cannot reproduce the problem.

Would you mind sharing your places.sqlite withg me through private mail?
Flags: needinfo?(mak77) → needinfo?(dqeswn)
(In reply to Marco Bonardo [::mak] from comment #5)
> I cannot reproduce the problem.
> 
> Would you mind sharing your places.sqlite withg me through private mail?

Me neither. The items were fixed when I moved the profile to aurora, and I didn't have a backup of the places file.
Flags: needinfo?(dqeswn)
Which sounds like a regression for Nightly. Avada, on Monday we had a version bump for Firefox, which means that your Aurora version 50.0a2 will be soon 51.0a2. So you should check again at this time if you see the issue again.
Didn't experience this since then.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.