Closed Bug 1302911 Opened 4 years ago Closed 4 years ago

HTML5 YouTube videos loop at point in video

Categories

(Core :: Audio/Video: Playback, defect, P1)

51 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1304347
Tracking Status
firefox49 --- unaffected
firefox50 --- ?
firefox51 --- disabled

People

(Reporter: parker.l.reed, Unassigned)

Details

(Keywords: regression, regressionwindow-wanted)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160914030200

Steps to reproduce:

1. Play YouTube video on the main website/embedded player




Actual results:

Video "stutters" for lack of a better word. If I jump to a certain point in a video the frame updates but the issue continues from that new point. Audio plays continuously without any issues.

ffmpeg 1:3.1.3-1
firefox-nightly 51.0a1.20160914-1

Video showing the issue https://www.youtube.com/watch?v=WzwKdOZg2ko


Expected results:

Video should play smoothly.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
I have seen this buggy behaviour too in comm-central builds, comm-beta doesn't have this problem.

The video stream loops the same 1 or 2 seconds, while the audio plays back and progresses normally , sometimes the problem goes away for a while but then randomly returns, I couldn't influence it

it happened with mp4 avc and webm vp9 video so it seems to be a bug in the html5 player code and not the codec backend, seems unrelated to the installed ffmpeg version 2.8 and 3.1 had the same issue.
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Parker, could you provide an URL with embedded YT video on the website to reproduce the issue, please.
Flags: needinfo?(parker.l.reed)
https://www.reddit.com/r/reallifedoodles/comments/52rqb3/brutal_penetration/d7n37kz

Clicking the expand button there (or clicking and loading directly)
Flags: needinfo?(parker.l.reed)
(In reply to Parker Reed from comment #3)
> https://www.reddit.com/r/reallifedoodles/comments/52rqb3/brutal_penetration/
> d7n37kz
> 
> Clicking the expand button there (or clicking and loading directly)

I don't see any embedded YT video here, just a link to a YT video: http://imgur.com/32GKPLE
If I click on the link, I'm redirected to YT website.

Are you using an add-on to enhance Reddit, like Reddit Enhancement Suite?

If yes, could you test in safe mode?
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
I am using RES but it was also happening on the main YouTube page. I'm not at that computer at the moment to test.
I installed RES on my Nightly profile, I'm not able to reproduce the video issue (e10s on/off).
I can't even seem to reliably reproduce this on that machine. It may happen on a video but I can go away to another page and come back and it starts working normally.
Somewhere between an update to 52.0a1.20160923-1 and an update to mesa (And all associated libs) it seems to be fixed. Could have just been an issue with my graphics card. (RX 480 so still fairly new)

If anybody else is having this issues, feel free to continue, of not then this can probably be closed.
Let's close it, feel free to reopen the bug report if the issue is back.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1304347
Mark 51 disabled per comment #39 in bug 1299860. It's only enabled in nightly.
You need to log in before you can comment on or make changes to this bug.