UI tests failing due to illegal-character

RESOLVED FIXED

Status

Tree Management
Treeherder
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: camd, Assigned: camd)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
SyntaxError: illegal character

  at /home/travis/build/mozilla/treeherder/ui/js/controllers/admin.js:9

But I don't see any odd character on that line.  Tests pass locally.  Looking...
(Assignee)

Comment 1

a year ago
The UI tests didn't like the es6 template syntax on Travis.  There are no UI tests for that file yet, so I should not have needed to include it in the karma config.  I moved the ``admin.js`` controller to the ``admin`` folder where it should have been anyway, and the problem is fixed.
Assignee: nobody → cdawson

Comment 2

a year ago
Created attachment 8791828 [details] [review]
[treeherder] mozilla:illegal-character-fix > mozilla:master

Comment 3

a year ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/03675d8b8217ee54a7f391d124b8d2dd84dee31b
Bug 1303215 - Fix UI test failure due to lack of es6 support (#1860)

The admin.js file has es6 templating syntax which is not considered
valid in our Karma tests.  This moves the admin controller to the
/admin folder where it should be anyway, so that the UI tests stop
failing.
(Assignee)

Comment 4

a year ago
This was just a file move, so I went ahead an merged it without a review.  I hope there aren't any objections.  I didn't want to leave master with broken tests till tomorrow.  Sorry, too, that I didn't notice this failure before merging.  My bad...
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.