JavaScript document.images[].src method fails on first use

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: don.livingston@shininghappypeople.net, Unassigned, NeedInfo)

Tracking

48 Branch
All
Unspecified
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

Dear Firefox team,

I have detected a bug in updating images via JavaScript in Firefox 48.02 under Windows 8.1 with Bing running on a Toshiba Satellite C55-B laptop.  My test URL is:

http://livingrussian.com/beginners-russian/firefoxproblem/type-numbers.html

To observe the bug:
1.  Open Firefox to any page.
2.  Open the URL I mentioned in a second tab.
3.  Type '1' (without the single quotes) in the first text box and press TAB.
4.  A green checkmark should appear to the left, and the '5' should be replaced by a bold 5 with yellow background.  The latter happens; the checkmark does not appear.
5.  Type '2' in the second text box.  I get expected behavior.
6.  Click on the other tab.  Then return to the first tab.  The green checkmark is now visible on the first line.

Summary:  essentially an image fails to update when javascript first attempts to change the image.  This did not occur in previous version of firefox over the last five years. 

Running on the same laptop this issue never appears under Internet Explorer version 11.0.9600.18205 with update version 11.02.08.  It also does not appear on the same laptop under Chrome version 52.0.2743.116.  I have found the same error on Firefox under Mac OS X.  It does not occur under Chrome on the Mac OS X.

All the best, Don Livingston.
(Reporter)

Updated

2 years ago
Hardware: Unspecified → All

Comment 1

2 years ago
Created attachment 8792004 [details]
Capture d’écran 2016-09-16 à 17.38.17.png

(In reply to don.livingston@shininghappypeople.net from comment #0)
> 3.  Type '1' (without the single quotes) in the first text box and press TAB.
> 4.  A green checkmark should appear to the left, and the '5' should be
> replaced by a bold 5 with yellow background.  The latter happens; the
> checkmark does not appear.

What's this '5'? Do you mean '1'?

Anyway, I see the green checkmak and the number '1' in a yellow square.
Flags: needinfo?(don.livingston)
Ah, so sorry.  That was a typo.  Point 4 should read:

"4.  A green checkmark should appear to the left, and the '1' should be
replaced by a bold 1 with yellow background.  The latter happens; the
checkmark does not appear."

I have just double checked, and the green checkmark is not appearing when it should.  I have also duplicated this problem on Firefox under OS X.
Firefox: 49.0, Build ID: 20160916101415
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

Hi Don,

I have tested this issue on the latest Firefox (49.0) release and latest Nightly (52.0a1) build, and the issue is no longer reproducible. I have also tested this on a old Firefox (48.0) release and I was able to reproduce it. It seems that this issue was already fixed. 

Can you please confirm that this issue is no longer reproducible on the latest Firefox release?
Cosmin,

Thanks!  I've downloaded 49.0, and you are right:  it is no longer reproducible.  I believe the issue has been resolved.

Don.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.