loading page in Mozilla locks entire computer

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
minor
RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: James Paige, Assigned: asa)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Hmmm...

Build 2002031108 on Linux

Whenever I visit
http://sundocs.princeton.edu:8888/ab2/coll.47.4/x86INFOLIB/@Ab2PageView/20173
the page starts to load, and then my entire system hangs. X server freezes.
Network card stops responding to pings. I have to hard-reboot and fsck

The totallity of this crash makes me suspicious that it must be some bigger
problem than just a Mozilla thing, as Linux is SUPPOSED to be stable enough that
one proggy can crash without bringing the world down, yet this is completely
reproduceable. Every time Mozilla trys to load this page, Zap! I am locked...
and I am not experiencing any other lockups or any other similar instability
under any other conditions neither in Mozilla nor in any other programs.

I pulled the offending page with wget and viewing the html file from my local
hard drive will lock up the same way. I shall attach it.

I will try to break it down into an even smaller test case... but I dont know if
I have the heart to do it. I cant stand lockups, and ever time I have to fsck my
/home partition, I die a little bit inside.
(Reporter)

Comment 1

16 years ago
Created attachment 73709 [details]
the venomous html file of death!

Here is the page as saved by wget

I am very curious to see if this locks up other people, or if it is simply me
who is cursed with this unspeakable evil.
wfm with a 1h old win2k build
Keywords: hang
worksforme, linux build 2002-03-11-08....  both original site and attachment.

Is your X or xfs barfing?
(Reporter)

Comment 4

16 years ago
hrmm. Still locking with build 2002031208

Boris: *everything* locks. My mouse freezes, I am unable to kill my X server
with CTRL+ALT+BACKSPACE, My network card stops returning Pings, and I cannot
force a reboot with CTRL+ALT+DEL. Also, I am not now, nor have I ever been
running xfs.

For the sake of information, this is what my system uses:

Debian 2.2 (stable)
Kernel 2.4.17 (from sources)
X 4.1.0 (from sources)
Window manager fvwm2 2.4.3 (from sources)

This page still locks me up every time. Nothing else causes a lockup (or has
EVER caused a lockup on this system... I think today is the first time I have
had to hard-reboot in the entire lifetime of this box. <sorrow>Waaaaah!</sorrow>)
(Reporter)

Comment 5

16 years ago
I tested this on my home box, which is configured pretty much the same with the
same versions of just about everything, and it isnt happening there.

Reducing the severity, as nobody else is suffering from this.

I will keep trying to figure out what about my config on that computer triggers
this.

As a side note, I took this opportunity to upgrade my system to support ext3
journaling file system, and wow! I am delighted with it. It is making this SO
much less painful to debug now that I can hard-reboot without having to suffer
the agony of a full fsck
Severity: critical → normal

Comment 6

16 years ago
WFM Linux 20020408 CVS

Marking WORKSFORME for the moment.

James: Marking this WFM since it does for everyone else :-) and in an effort to
try and reduce the sheer number of unconfirms there are. Of course if this is
still a problem, REOPEN with the up-to-date build stuff and the fun can continue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
Well, as of build 2002040908, it still locks me hard.

However, I find that if I try with a fresh profile, It does not lock, so I am
marking this VERIFIED WORKSFORME

However, I categorically refuse to delete my profile and start with a fresh one.
It just goes against the grain of everything I believe, everything I hold dear.
I will, time permitting, continue to seek what exactly about my profile makes it
crash on this page, and when I find out I will post it here.



Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

16 years ago
ARGH! Sorry. I recant. I *can* reproduce this on a brand new profile with linux
build 2002040908

I spend almost an hour this morning deleting various combinations of the files
in my profile, trying to figure out which was the corrupt one, but I was unable
to figure it out.

Finally I discovered that I could reproduce this on a fresh clean profile like so:

1) Create new pofile, run with new profile.

2) Either hide the sidebar by pressing F9 AND/OR maximize the window

3) Attempt to view the atachment to this bug

4) hard lock up every time.

If I skip step 2, and leave the window *exaclty* as it was when it first opened,
then the page loads fine with no lockup.

... but certainly there must be more to it than this, because I find it hard to
believe that none of the people who posted WFM on this bug had ever maximized
their windows or hidden their sidebars...

I am re-opening this bug, but keeping it at a low severity, as it I am still the
only *known* victim
Severity: normal → minor
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

16 years ago
WFM with 1.0RC1 on Linux.

That page opened in 3 seconds flat in its entirety.  However, for about 1 second
of that, it seemed that Mozilla is "straining" because the screen began slightly
"rippling" as it does when something is running at 100% CPU for me.

Could you tell us your Linux distro and version, and the type of filesystem
you're using?  I don't know if that'll make a difference, but more info couldn't
hurt.

Comment 10

16 years ago
wfm, 2002062408/linux.
James, still crashing?
(Reporter)

Comment 11

16 years ago
Linux trunk build 2002062713

Hard lock, as described before :(

I just tried it with the exact same build on my Laptop. No lockup, no problem. I
have never been able to reproduce this on my home box either.

Just this one computer does it every time (which has never had any other
problems even remotely like this in any other place in mozilla, or any other
program)

Philip: I am using Debian 2.2 (potato) and EXT3 filesystem.

still with 1.1beta?
(Reporter)

Comment 13

16 years ago
No good :(
hard lock, Linux trunk build 2002080808
hm... could you thy it with a clean install or even with a fresh profile
(mozilla -profileManager and then let it create another one)?
(Reporter)

Comment 15

16 years ago
Been there, done that. See comment 8
oh.. didn't see. As the page doesn't load for me, are there any plugins used?
(Reporter)

Comment 17

16 years ago
no, I don't grep any EMBED or OBJECT tags in the file. Just to try, I removed
all of my plugins and viewed it, but it still locked me up.
(Reporter)

Comment 18

16 years ago
I ahve retired the computer on which I could reproduce this, and I can not
reproduce it on my new computer, or any of my other computers, and nobody else
can reproduce it, so I am going to give up and mark this WORKSFORME

I think we need a new "Fixed" resolution called VOODOOCURSE
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.