Selecting text in a displayed message and pressing delete (forgot to click "answer") will delete the message.

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Müller, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

Version 45.3.0 French
I start editing the original mail, especially deleting parts of it.


Actual results:

The original mail disappears and I can't recover it.


Expected results:

The operation should be rejected with an error message and without loss of information.

Comment 1

2 years ago
I don't understand at all what you're talking about. Thunderbird does *not* let you edit an original received message. Are you using an add-on? (Last I looked, Outlook let's you edit messages.)

That said, yes, there are ways to recover superseded messages, in case the original message was superseded. But that's a support query that we don't answer here. See for example:
https://www.google.com.au/?gws_rd=ssl#q=thunderbird+recover+deleted+emails

All you can do in TB is delete attachments and there is a big warning message that you can't undo that.
(Reporter)

Comment 2

2 years ago
Thanks for your fast answer.
What I was talking about is :
- you want to answer the e-mail that's on your screen
- you forget to hit the answer button and start to edit the original message
- you select some part of its contents and hit delete
- without any warning your original mail vanishes and is no longer to find anywhere, especially not in the waste basket

May be I'm the only one to whom this occasionally happens. Mea culpa ! but I find this behaviour of Thunderbird unfriendly.

Comment 3

2 years ago
(In reply to Müller from comment #2)
> What I was talking about is :
> - you want to answer the e-mail that's on your screen
> - you forget to hit the answer button and start to edit the original message
Sorry, you cannot edit the original message since its display is "readonly" !!

> - you select some part of its contents and hit delete
> - without any warning your original mail vanishes and is no longer to find
> anywhere, especially not in the waste basket

Ah, you select some text and then hit delete. The whole message is deleted. Oops.

It goes into the trash folder. Also, you can use "Edit > Undo" to undelete it. Undo is not one of our best features, but it does work in that case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Updated

2 years ago
Summary: If i forget to hit 'Answer to this mail' and start editing the original, this one disappears. Any possiblity to recover it ? → Selecting text in a displayed message and pressing delete (forgot to click "answer") will delete the message.
You need to log in before you can comment on or make changes to this bug.