Closed Bug 1303301 Opened 3 years ago Closed 3 years ago

Crash in mozilla::WebGLContext::ThrowEvent_WebGLContextCreationError

Categories

(Core :: Canvas: WebGL, defect, critical)

50 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox50 --- fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: patclash, Assigned: sotaro)

References

Details

(Keywords: crash, regression, Whiteboard: [tbird topcrash])

Crash Data

Attachments

(1 file, 1 obsolete file)

This bug was filed from the Socorro interface and is 
report bp-ee0a42d9-8fe8-4e6b-b698-7e7fa2160916.
=============================================================

Crash when open Troubleshooting Information since buildID=20160915004004

Reproducible : always

Last build that don't crash is buildID=20160914004004
jorg or aceman might have a good guess at what's causing this, they are at the forefront of many of the changes :)
When Jorg fixed the troubleshooting page, it may now actually run the GPU tests needed to populate the page.

I'd first run this through the core GPU guys as the stack looks like it may be a problem in WebGL core. Often probing GPU/OpenGL features may provoke driver bugs.
Component: General → Graphics
Product: Thunderbird → Core
(In reply to :aceman from comment #2)
> When Jorg fixed the troubleshooting page, ...
You know what? It was absolute synchronicity that bug 1281785 landed (fixed the graphics section) when I got graphics errors due to some overzealous reporting which has since been fixed in M-C (bug 1302713). Only due to this coincidence did I notice that errors weren't reported properly in TB's Troubleshooting Information.
#1 crash for https://crash-stats.mozilla.com/topcrashers/?product=Thunderbird&version=50.0a2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [tbird topcrash]
[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

Regression window:
Last Good:
http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32/1473799447/

First crash:
http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32/1473839167/

Pushlog:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=c482d8a2cd6178a9e5990c07b6c7c09dc63d919d&tochange=44003aa9b4def847e79458ca5756e50c1f0032b3
https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2016-09-13+13%3A00%3A00&enddate=2016-09-14+01%3A00%3A00

Regressed by:
77a72b7f61d4	Sotaro Ikeda — Bug 1281785 - JavaScript error: chrome://messenger/content/about-support/gfx.js, line 46: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]. r=mkmelin
It is need to re-check after landing Bug 1303741 on m-c.
s/Bug 1303741 on m-c/Bug 1300562 on c-c/
Flags: needinfo?(sotaro.ikeda.g)
nullptr dereference happened. It seems like a bug of WebGLContext::ThrowEvent_WebGLContextCreationError(). It expects canvas element or offscreen canvas.
Component: Graphics → Canvas: WebGL
Flags: needinfo?(sotaro.ikeda.g)
Assignee: nobody → sotaro.ikeda.g
(In reply to Sotaro Ikeda [:sotaro] from comment #10)
> nullptr dereference happened. It seems like a bug of
> WebGLContext::ThrowEvent_WebGLContextCreationError(). It expects canvas
> element or offscreen canvas.

When WebGLContext is called by GfxInfoWebGL::GetWebGLParameter(), the WebGLContext does not have canvas element nor offscreen canvas.
Attached patch patch - Add nullptr handling (obsolete) — Splinter Review
Attachment #8792761 - Flags: review?(jgilbert)
Tracked as it's a new issue in Fx50.
[Tracking Requested - why for this release]:

(In reply to Ritu Kothari (:ritu) from comment #13)
> Tracked as it's a new issue in Fx50.

Ritu, I believe this is Thunderbird only crash.
Attachment #8792761 - Flags: review?(jgilbert) → review?(mtseng)
Ooops my bad, don't think we need to track this from our side.
Attachment #8792761 - Flags: review?(mtseng) → review+
backed out for failures like https://treeherder.mozilla.org/logviewer.html#?job_id=36694393&repo=mozilla-inbound
Flags: needinfo?(sotaro.ikeda.g)
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cb3ef16e7648
Backed out changeset ca17ce6a2c9a for gl3 test failures
(In reply to Carsten Book [:Tomcat] from comment #17)
> backed out for failures like
> https://treeherder.mozilla.org/logviewer.html#?job_id=36694393&repo=mozilla-
> inbound

Sorry, I did silly mistake :(
Flags: needinfo?(sotaro.ikeda.g)
Attachment #8792761 - Attachment is obsolete: true
Attachment #8796405 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/95a97f6e3abf
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
This is a topcrash for TB51 - so can this be uplifted to 51?
Comment on attachment 8796405 [details] [diff] [review]
patch - Add nullptr handling

I'll try filling in the form, Sotaro-san can you help, please.

Approval Request Comment
[Feature/regressing bug #]: ?
[User impact if declined]: CRASH!!
[Describe test coverage new/current, TreeHerder]: Yes, covered by test-suite.
[Risks and why]: Low, just added a null pointer check.
[String/UUID change made/needed]: None.
Flags: needinfo?(sotaro.ikeda.g)
Attachment #8796405 - Flags: approval-mozilla-aurora?
Approval Request Comment
[Feature/regressing bug #]: Bug 1271478 and bug 1281785  
[User impact if declined]: CRASH happens when using Thunderbird.
[Describe test coverage new/current, TreeHerder]: Yes, covered by test-suite.
[Risks and why]: Low, just added a null pointer check.
[String/UUID change made/needed]: None.
Flags: needinfo?(sotaro.ikeda.g)
Blocks: 1271478
Actual bug was injected by Bug 1271478, but it was masked until bug 1281785 fix. Since bug 1281785 fix, the bug was exposed on Thunderbird and caused the crash.
Comment on attachment 8796405 [details] [diff] [review]
patch - Add nullptr handling

Fix a crash. Take it in 51 aurora.
Attachment #8796405 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Just to thanks all :

That bug is fixed in today build (20161007004005)

:)
This fix does been ported to 50.0b1 too !
same crash on first try :(
Flags: needinfo?(sotaro.ikeda.g)
Flags: needinfo?(sotaro.ikeda.g)
Comment on attachment 8796405 [details] [diff] [review]
patch - Add nullptr handling

Approval Request Comment
[Feature/regressing bug #]: Bug 1271478 and bug 1281785  
[User impact if declined]: CRASH happens when using Thunderbird.
[Describe test coverage new/current, TreeHerder]: Yes, covered by test-suite.
[Risks and why]: Low, just added a null pointer check.
[String/UUID change made/needed]: None.
Attachment #8796405 - Flags: approval-mozilla-beta?
Comment on attachment 8796405 [details] [diff] [review]
patch - Add nullptr handling

Null check, crash fix, Beta50+
Attachment #8796405 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.