Cursor does not always move forward for spaces in input boxes in 0.9.9

VERIFIED WORKSFORME

Status

()

Core
Editor
P3
normal
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Geva Patz, Assigned: kinmoz)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
BuildID:    2002031104

Ofen, when filling in input boxes in 0.9.9, the cursor will not move forward 
when I type a space. The same effect happens if I delete characters. Say, for 
example, I type "RED DOG", and then delete the letters G-O-D in that order. The 
cursor will immediately jump to the 'D' in RED, rather than the space after it. 
The spaces are recorded correctly (as soon as I type a character, it appears in 
the correct place and the cursor moves after it). This doesn't seem to happen in 
all forms for some reason, but it does happen on some forms (notably the ones on 
the Mozilla website) for both single and multi-line input boxes.

Reproducible: Sometimes
Steps to Reproduce:
1. Type text with spaces in it into an input box

Actual Results:  The cursor sits to the left of each space

Expected Results:  The cursor should sit to the right of each space, as with 
other characters.

This was not a problem in any previous version of Mozilla -- I have made no 
configuration changes other than installing the new version.
(Reporter)

Updated

17 years ago
Component: Networking → Form Submission
(Reporter)

Comment 1

17 years ago
Corrected incorrect component category.
Assignee: new-network-bugs → rods
Component: Form Submission → HTML Form Controls
QA Contact: benc → madhur

Comment 2

17 years ago
-->core
Assignee: rods → kin
Component: HTML Form Controls → Editor: Core
QA Contact: madhur → sujay
(Assignee)

Comment 3

17 years ago
I can't reproduce this bug with the steps mentioned and the URL supplied:

  http://www.mozilla.org/quality/help/bugzilla-helper.html

in my Mozilla Win32 debug build. This sounds almost like bug 87314.
Priority: -- → P3
Target Milestone: --- → mozilla1.1

Comment 4

17 years ago
I am using 0.9.9 on w2k. I confirm the problem.
When I first load the page, I get the white rectangle.
When I relaod, the white rectangle disappears. Buf if I click on the page,
switch tab, change application focus, the problem reappears again.

There are also problems with the code supposed to change the image and the link
to open the menu when the mouse is over it. It doesn't work on Mozilla but works
on IE 6.0
I noted that there are plenty of javascript errors in the console.

The 2 problems may then be related and due to javascript, as I think it is used
to do image preloading. Or perhaps there are 2 different problems, one from
javascript, the other from context.

Comment 5

17 years ago
damn wrong bug. I meant bug 130258. Forget my last comment.
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.1alpha → Future

Comment 6

16 years ago
WFM with 2002091908/trunk/win2k.

reporter (Geva): can you reproduce this bug with a recent build of mozilla (for
example, 1.2alpha)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 7

16 years ago
Works in 1.2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
cool. thanks.

verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.