Closed Bug 1303533 Opened 3 years ago Closed 3 years ago

windows 10 artifact builds are not working when Visual Studio not installed due to missing MIDL

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox52 fixed)

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: jmaher, Assigned: chmanchester)

References

Details

Attachments

(2 files)

I have a fresh windows 10 machine, I setup with mach bootstrap and chose option 2 (firefox for desktop). Note, this is not the artifact build version.

next, I followed the steps here:
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Artifact_builds

and did:
./mach clobber
./mach build

I end up with:
 2:41.56 Elapsed: 0.00s; From dist/public: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
 2:41.75 Elapsed: 0.16s; From dist/branding: Kept 0 existing; Added/updated 15; Removed 0 files and 0 directories.
 2:42.09 Elapsed: 0.01s; From dist/private: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
 2:42.63 Elapsed: 0.14s; From dist/sdk: Kept 2 existing; Added/updated 7; Removed 0 files and 0 directories.
 2:43.26 Elapsed: 0.29s; From dist/xpi-stage: Kept 2 existing; Added/updated 13; Removed
0 files and 0 directories.
 2:47.16 Elapsed: 5.60s; From dist/idl: Kept 0 existing; Added/updated 1139; Removed 0 files and 0 directories.
 2:47.55 source-repo.h
 2:47.61 buildid.h
 2:48.70 Makefile:25: recipe for target 'done_gen' failed
 2:48.72 process_begin: CreateProcess(NULL, midl -Oicf c:/Users/elvis/mozilla-inbound/accessible/ipc/win/typelib/Accessible.idl, ...) failed.
 2:48.72 make (e=2): The system cannot find the file specified.
 2:48.72
 2:48.72 mozmake.EXE[6]: *** [done_gen] Error 2
 2:48.73 c:/Users/elvis/mozilla-inbound/config/faster/rules.mk:75: recipe for target 'c:/Users/elvis/mozilla-inbound/objdir-frontend/accessible/ipc/win/typelib/Accessible.tlb' failed
 2:48.73 mozmake.EXE[5]: *** [c:/Users/elvis/mozilla-inbound/objdir-frontend/accessible/ipc/win/typelib/Accessible.tlb] Error 2
 2:48.73 mozmake.EXE[5]: *** Waiting for unfinished jobs....
 2:49.18 Elapsed: 5.83s; From _tests: Kept 0 existing; Added/updated 1088; Removed 0 files and 0 directories.
 2:50.13 Makefile:179: recipe for target 'faster' failed
 2:50.13 mozmake.EXE[4]: *** [faster] Error 2
 2:50.13 mozmake.EXE[4]: *** Waiting for unfinished jobs....
 2:52.11 Elapsed: 10.53s; From dist/include: Kept 0 existing; Added/updated 4212; Removed 0 files and 0 directories.
 2:52.11 c:/Users/elvis/mozilla-inbound/config/recurse.mk:32: recipe for target 'pre-export' failed
 2:52.11 mozmake.EXE[3]: *** [pre-export] Error 2
 2:52.11 c:/Users/elvis/mozilla-inbound/config/rules.mk:539: recipe for target 'default'
failed
 2:52.11 mozmake.EXE[2]: *** [default] Error 2
 2:52.11 c:/Users/elvis/mozilla-inbound/client.mk:413: recipe for target 'realbuild' failed
 2:52.11 mozmake.EXE[1]: *** [realbuild] Error 2
 2:52.11 client.mk:168: recipe for target 'build' failed
 2:52.11 mozmake.EXE: *** [build] Error 2
 2:52.17 0 compiler warnings present.
2

elvis@JMAHER-WIN10 ~/mozilla-inbound
$
I started the mozilla-build shell incorrectly using start-shell.bat instead of the right version for my platform vs2015 stuff.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
start-shell.bat should just work on mozilla-central. I've been using start-shell.bat for a while without problems.

I'd like to get to the bottom of this, so reopening the bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Looks like we perform MIDL foo during artifact builds on Windows. We should probably not do that.
Status: REOPENED → NEW
Summary: windows 10 artifact builds are not working → windows 10 artifact builds are not working when Visual Studio not installed due to missing MIDL
Duplicate of this bug: 1314444
Assignee: nobody → cmanchester
Comment on attachment 8806526 [details]
Bug 1303533 - Don't traverse accessible/ipc/win/typelib during Artifact builds.

https://reviewboard.mozilla.org/r/89924/#review89642
Attachment #8806526 - Flags: review?(mshal) → review+
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d1ca12a26ed8
Don't traverse accessible/ipc/win/typelib during Artifact builds. r=mshal
https://hg.mozilla.org/mozilla-central/rev/d1ca12a26ed8
Status: NEW → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.