If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

textbox's autocompletesearch=history stopped working in Firefox 49

RESOLVED WONTFIX

Status

()

Toolkit
Autocomplete
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: Denis, Unassigned)

Tracking

({regression})

49 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox48 unaffected, firefox49 affected, firefox50 affected, firefox51 affected)

Details

Attachments

(1 attachment)

1.53 KB, application/x-xpinstall
Details
(Reporter)

Description

a year ago
Created attachment 8792307 [details]
addon-textbox-autocomplete.xpi

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160817112116

Steps to reproduce:

I added <textbox type="autocomplete" autocompletesearch="history"/> on a XUL page.


Actual results:

When I entered a short phrase in the box no suggestions appeared, although some history records with the phrase were existing.


Expected results:

Textbox should suggest history records if they are available and match entered phrase.

I'm attaching a test addon, please install it and visit chrome://fftestaddon/content/test.xul, it's the page with the textbox. The addon works fine in Firefox 48, but not in 49.

Comment 1

a year ago
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=738ec20418cc728910419aa60f98ae62b429facf&tochange=44a989cf6c1662b60e3113cb6503817b7fc31131

It's a consequence of bug 1223728.

Marco, your thoughts about this case?
Blocks: 1223728
Component: Untriaged → Autocomplete
Flags: needinfo?(mak77)
Keywords: regression
Product: Firefox → Toolkit
status-firefox48: --- → unaffected
status-firefox49: --- → affected
status-firefox50: --- → affected
status-firefox51: --- → affected
history search component is gone, the only supported search component is "unifiedcomplete".
If you need help with that, feel free to ping me, but this is not a bug we plan to fix, the old component was just deprecated and removed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(mak77)
Resolution: --- → WONTFIX
ps: just as a side note, you can clearly write your own search component, as well as importing the old nsPlacesAutocomplete.js component into your add-on.
This is the current search implementation, if you're looking for an example (quite complex actually for your purposes but may contain useful hints): http://searchfox.org/mozilla-central/source/toolkit/components/places/UnifiedComplete.js
And this is the old component (that soon will be moved to comm-central repository and disappear from here): http://searchfox.org/mozilla-central/source/toolkit/components/places/nsPlacesAutoComplete.js
(Reporter)

Comment 4

a year ago
Marco, thank you for the useful information! I imported the old history autocomplete component and it seems it works fine for me.
You need to log in before you can comment on or make changes to this bug.