Mozilla crashes on launch

RESOLVED DUPLICATE of bug 130271

Status

SeaMonkey
General
--
blocker
RESOLVED DUPLICATE of bug 130271
17 years ago
14 years ago

People

(Reporter: Prachi Gauriar, Assigned: asa)

Tracking

({crash, regression})

Trunk
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.12; Mac_PowerPC)
BuildID:    20020312

Mozilla crashes on the splash screen. Worked with yesterday's nightly, doesn't work today's. Deleting profile 
doesn't fix this problem.

Reproducible: Always
Steps to Reproduce:
1. Launch Mozilla from the Finder

Actual Results:  Mozilla crashes on splash screen

Expected Results:  Mozilla should start up.

I use an Apple Powerbook G3 500mHz Powerbook with 512mb RAM and Mac OS X 10.1.3 w/Java 
update. 

Here's a stack trace:

Date/Time:  2002-03-12 14:39:42 -0600
OS Version: 10.1.3 (Build 5Q45)
Host:       enigma

Command:    Mozilla
PID:        522

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
 #0   0x0273a2c4 in nsWindowMediator::Assert(nsIRDFResource *, nsIRDFResource *,  *)
 #1   0x02137b58 in RDFServiceImpl::GetLiteral(wchar_t const *, nsIRDFLiteral **)
 #2   0x02154e94 in MakeContainer__21RDFContainerUtilsImplFP16nsIRDFDataSourceP14n
 #3   0x0215478c in MakeSeq__21RDFContainerUtilsImplFP16nsIRDFDataSourceP14nsIRDFR
 #4   0x02739958 in nsWindowMediator::Init(void)
 #5   0x027371c0 in nsWindowMediator::_ct(void)
 #6   0x027312cc in nsWindowMediatorConstructor(nsISupports *, nsID const &, void **)
 #7   0x0056f9ec in nsGenericFactory::CreateInstance(nsISupports *, nsID const &, void **)
 #8   0x0057b580 in nsComponentManagerImpl::CreateInstance(nsID const &, nsISupports *)
 #9   0x0057bb2c in nsComponentManagerImpl::GetService(nsID const &, nsID const &, void **)
 #10  0x00576194 in nsGetServiceByCID::_cl( const(nsID const &, void **))
 #11  0x00606ddc in nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const &, nsID const &)
 #12  0x02732280 in Initialize__17nsAppShellServiceFP17nsICmdLineServiceP11nsISupp
 #13  0x004b5f5c in main1(int, char **, nsISupports *)
 #14  0x004b6cfc in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x70283ea4 in TSWaitOnConditionTimedRelative
 #3   0x7027d748 in TSWaitOnSemaphoreCommon
 #4   0x702c2078 in TimerThread
 #5   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

PPC Thread State:
  srr0: 0x0273a2c4 srr1: 0x0000d030                vrsave: 0x00000000
   xer: 0x00000018   lr: 0x02154e94  ctr: 0x0273baf0   mq: 0x00000000
    r0: 0x02154e94   r1: 0xbffff140   r2: 0x020a8000   r3: 0x00000000
    r4: 0x0270f7c0   r5: 0x01f88020   r6: 0x01f9de30   r7: 0x00000001
    r8: 0x0215ec8c   r9: 0x80240e10  r10: 0x00000024  r11: 0x80003710
   r12: 0x020a8d70  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0x00000000  r19: 0x00000000
   r20: 0x00000000  r21: 0x00000000  r22: 0x00000000  r23: 0x01f87f80
   r24: 0x00000000  r25: 0x01d18284  r26: 0x0270f7c0  r27: 0x020af658
   r28: 0x01c87464  r29: 0x01c874dc  r30: 0x006e13a0  r31: 0x006e1254

**********

Comment 1

17 years ago
confirming using build 2002031203 on Win2k. Talkback ID (if needed): TB3960883G.
OS -> All.
Severity -> Blocker.
Severity: critical → blocker
Keywords: crash, regression
OS: MacOS X → All
Hardware: Macintosh → All

Comment 2

17 years ago
Marking NEW although Brower General is not the greatest component to choose... 
RDF ?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 130271 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.