Port Jinja2 templates to Django for ATMO

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
2 years ago
4 months ago

People

(Reporter: jezdez, Assigned: jezdez)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
As part of setting up django-allauth for the Google Auth integration in bug 1273037, :mdoglio and me decided to move away from Jinja2 for the atmo rewrite for now to be able to use 3rd party applications without incurring a big amount of overhead and technical debt at the same time. While Jinja2 templates are currently possible in Django (e.g. with help of django-jinja) atmo won't be requiring the performance advantages and feature set of Jinja2 due to its character as an internal tool. We may reconsider using Jinja2 at a later stage if needed.
(Assignee)

Updated

2 years ago
Assignee: nobody → jezdez
Blocks: 1273037
Status: NEW → ASSIGNED
Priority: -- → P1
Created attachment 8792459 [details] [review]
[telemetry-analysis-service] mozilla:django-templates > mozilla:master
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1303311
Created attachment 8793719 [details] [review]
[telemetry-analysis-service] mozilla:template-syntax-error > mozilla:master

Updated

4 months ago
Product: Cloud Services → Cloud Services Graveyard
You need to log in before you can comment on or make changes to this bug.