Bluetooth Mouse can connect and work but the cursor is not visible

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Bluetooth
--
enhancement
RESOLVED WONTFIX
2 years ago
3 months ago

People

(Reporter: Novski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160817112116

Steps to reproduce:

I connected a Mouse because i whanted to test the Bluetooth connection and noticed that it actualy works but i was stearing blind because ther was no cursor visible. In fact i was able to gess where it is and open different apps. So it seam as if it wold work to use a Bluetooth mouse on B2GOS but the cursor doesn't apear.
(Reporter)

Updated

2 years ago
Severity: normal → enhancement
Component: General → Gaia::Bluetooth
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Novski from comment #0)
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0)
> Gecko/20100101 Firefox/48.0
> Build ID: 20160817112116
> 
> Steps to reproduce:
> 
> I connected a Mouse because i whanted to test the Bluetooth connection and
> noticed that it actualy works but i was stearing blind because ther was no
> cursor visible. In fact i was able to gess where it is and open different
> apps. So it seam as if it wold work to use a Bluetooth mouse on B2GOS but
> the cursor doesn't apear.

Hi
We support BT HID, but unfortunately we don't have any support to paint any mouse cursor in b2g.
I think we can't do much about it from bluetooth. Someone needs to work on mouse cursor.

Comment 2

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.