Closed Bug 1303860 Opened 4 years ago Closed 4 years ago

desktop-test image contains 1+ GB of mesa package files

Categories

(Testing :: General, defect)

Version 3
defect
Not set
normal

Tracking

(firefox52 fixed)

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: gps, Assigned: gps)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

ubuntu1204-test-system-setup.sh downloads a 590,643,702 byte mesa-repo-9.2.1-1ubuntu3~precise1mozilla2.tgz file containing tons of .deb files. Both this file and the extracted .deb files are part of the final Docker image, bloating the image size by over 1 GB.

This wasted space can contribute significant overhead to job execution, as that is 1 GB that needs to be transferred to workers and loaded into Docker.
Comment on attachment 8792660 [details]
Bug 1303860 - Don't change directory when installing Mercurial;

https://reviewboard.mozilla.org/r/79580/#review78244

From a look around, the issue is that install-mercurial.sh changes the cwd (to /usr/local/mercurial) and doesn't change it back.  So all that stuff got downloaded to /usr/local/mercurial and the cleanup of /setup at the end didn't delete it.

The pushd/popd fix here doesn't seem right, not least because the pushd is for the same directory the scripts `cd` to a few dozen lines earlier.  I'd prefer to see install-mercurial be a bit better behaved, perhaps by using pushd/popd when it runs the tooltool fetch, or even just fetching robustcheckout.py locally and moving it to /usr/local/mercurial.

At any rate, r+ since this will fix a serious issue.. just not quite the way I'd like!
Attachment #8792660 - Flags: review?(dustin) → review+
Comment on attachment 8792660 [details]
Bug 1303860 - Don't change directory when installing Mercurial;

https://reviewboard.mozilla.org/r/79580/#review78246

Much better!
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/efe0f5cfb537
Don't change directory when installing Mercurial; r=dustin
https://hg.mozilla.org/mozilla-central/rev/efe0f5cfb537
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.