DisplayName from addressbook not used in REPLY

UNCONFIRMED
Unassigned

Status

--
enhancement
UNCONFIRMED
2 years ago
2 years ago

People

(Reporter: michaelof, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160818000000

Steps to reproduce:

I have a contact in my adressbook with recently changed last name / Display name (newly-wed woman :-)). 

Recently in real life, she didn't change it technically at her ISP/email provider.

So I changed her LastName and DisplayName in my adressbook to reflect the NEWLastName. 
Followed (of course) https://support.mozilla.org/en-US/kb/display-name-message-list-and-message-pane, received messages are shown with DisplayName of my addressbook, so NEWLastName.

Precondition: Received email from this contact exists


Actual results:

- When I click on "REPLY", the DisplayName from the received email is taken (so OLDLastName...) , NOT the DisplayName from the addressbook (NEWLastName...).

- The original email body is appened below a line containing "OLDLAstName.... wrote ...."



Expected results:

If "Always prefer display name over message header" is set like explained in https://support.mozilla.org/en-US/kb/display-name-message-list-and-message-pane, I would have expected that this addressbook DisplayName is also used for REPLYed emails

Comment 1

2 years ago
(In reply to Michael from comment #0)
> If "Always prefer display name over message header" is set like explained in
> https://support.mozilla.org/en-US/kb/display-name-message-list-and-message-
> pane, I would have expected that this addressbook DisplayName is also used
> for REPLYed emails

The source you're quoting explains how the display name is used in the thread pane (message list). I wouldn't derive from that, that it should also be used in replies. The recipient used in a reply comes from the e-mail headers and the address book display name doesn't override that. Should it, Magnus?
Flags: needinfo?(mkmelin+mozilla)
No, it shouldn't.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mkmelin+mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 273511
(Reporter)

Comment 3

2 years ago
Hi Magnus,


after reading Bug 1303881 I don't agree that my issue is a duplicate. 

Bug 1303881 is discussing using DisplayName from AdressBook calling this "beautifying". The discussion starts in 2004 and ends in 2008, except comment 9 (https://bugzilla.mozilla.org/show_bug.cgi?id=273511#c9)

The difference to this (my) bug is, that now, long after 2008, as described an option "ALYWAYS prefer display name over message header" has been introduced to TB, and my issue is about the not comprehensible way TB handles "ALWAYS".

I agree to Bug 1303881, that using the AdressBook DisplayNames as a general default wouldn't be good idea, because of the side effects discussed there.

But if I have an option "ALWAYS" I would like to get "ALWAYS" treated as "ALWAYS", not as "sometimes, but not doecumented if an when" ;-)

And I totally agree to comment 9 (https://bugzilla.mozilla.org/show_bug.cgi?id=273511#c9) in Bug 1303881, there's no real difference between sending a NEW Email and REPLY-ing to an email.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

2 years ago
Let's make this an enhancement. Bug 273511 comment #9 calls for a configurable option so some sort.

Note that Thunderbird is currently maintained be a group of stressed, over-worked and unpaid volunteers. So if you want this implemented, you'd have to do it yourself or hire someone with the right skill set to do it.
Severity: normal → enhancement

Updated

2 years ago
Component: Untriaged → Address Book

Updated

2 years ago
Component: Address Book → Message Compose Window
You need to log in before you can comment on or make changes to this bug.