When a profile was once opened in Nightly, it throws lots of "Unhandled promise rejection" and breaks addons in older versions

RESOLVED DUPLICATE of bug 1092090

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1092090
2 years ago
2 years ago

People

(Reporter: fireattack, Unassigned)

Tracking

({regression})

Trunk
All
Unspecified
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.27 Safari/537.36

Steps to reproduce:

1. Create or open a profile in Nightly (currently 52.0a1 (2016-09-19))
2. Install RES (https://addons.mozilla.org/en-US/firefox/addon/reddit-enhancement-suite/ )
3. Open https://www.reddit.com/ . You can confirm it's working by looking at the gear icon on top right corner.
4. Close Nightly, and re-open the same profile in Beta (49 at the moment).
5. Open https://www.reddit.com/ . Now you will realize RES is totally broken (there is no gear there): and it throws lots of "Unhandled promise rejection" error in console.
(Reporter)

Updated

2 years ago
Keywords: regression
(Reporter)

Comment 1

2 years ago
It definitely a regression; I test stuff on Nightly a lot and never run into problem until recently. But it's hard (at least for me) to find the regression window since it requires two versions to test..
Reproducible with Beta Version 49.0b6 also w/ 49.0b10
reddit-enhancement-suite:  Unhandled promise rejection Object {  }  sandbox.js:340
Not Reproducible with Beta Version 	50.0b1
Has STR: --- → yes
Hardware: Unspecified → All
(In reply to Benjamin Peng from comment #0)
> 1. Create or open a profile in Nightly (currently 52.0a1 (2016-09-19))
> 2. Install RES
> (https://addons.mozilla.org/en-US/firefox/addon/reddit-enhancement-suite/ )
> 3. Open https://www.reddit.com/ . You can confirm it's working by looking at
> the gear icon on top right corner.
> 4. Close Nightly, and re-open the same profile in Beta (49 at the moment).


We don't generally support down-grading from pre-release channels - there can be bugs or intentional changes in Nightly that modify the profile in ways that will no longer work for "older" channels (Release, Beta, Aurora.)

However we do know that people do this for various reasons, so if this is an intentional change it would be good to understand why it's happening.


> 5. Open https://www.reddit.com/ . Now you will realize RES is totally broken
> (there is no gear there): and it throws lots of "Unhandled promise
> rejection" error in console.


I notice too that if I reinstall RES at this point, it shows a dialog with a link to bug 944918.

After reading the comments there, I suspect this is a dupe of 1092090.

Mark do you agree?
Flags: needinfo?(standard8)
(Reporter)

Comment 5

2 years ago
>this is a dupe of 1092090

I suspect that too before I reported, but that one seems very old (ver. 33?) and I'm not sure why I never saw this problem until this year considering I switch between channels semi-frequently.

But if it's true feel free to mark as dupe.
It looks like the schema version has been bumped again (in FF 50). So this is essentially the same as that bug 1092090 - although it was reported earlier, its something we can't do a lot about (see bug 1092090 comment 19).

I'll mark this as duplicate though.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(standard8)
Resolution: --- → DUPLICATE
Duplicate of bug: 1092090
You need to log in before you can comment on or make changes to this bug.