[PATCH] crash switching from modern to wood

RESOLVED DUPLICATE of bug 77716

Status

Core Graveyard
Skinability
--
critical
RESOLVED DUPLICATE of bug 77716
17 years ago
10 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

({crash})

Trunk
x86
FreeBSD
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

844 bytes, patch
Ben Goodger (use ben at mozilla dot org for email)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

17 years ago
freebsd trunk today, no interesting patches
the code nearby is:
 if (aAdd)
   SetScrollbarVisibility(mVScrollbarBox, aAdd);

 nsSize vSize;
 mVScrollbarBox->GetPrefSize(aState, vSize);

(gdb) p mVScrollbarBox
$6 = (nsIBox *) 0x0

#0  0x2a2adf0b in nsGfxScrollFrameInner::AddRemoveScrollbar (this=0x8626ac0, aState=@0xbfbfbbb8, aScrollAreaSize=@0xbfbfba20, aOnTop=1, aHorizontal=0,
    aAdd=0) at /home/timeless/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp:1016
#1  0x2a2adda4 in nsGfxScrollFrameInner::RemoveVerticalScrollbar (this=0x8626ac0, aState=@0xbfbfbbb8, aScrollAreaSize=@0xbfbfba20, aOnRight=1)
    at /home/timeless/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp:981
#2  0x2a2ae5b2 in nsGfxScrollFrameInner::Layout (this=0x8626ac0, aState=@0xbfbfbbb8)
    at /home/timeless/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp:1233
#3  0x2a2ae0ed in nsGfxScrollFrame::DoLayout (this=0x86b13ec, aState=@0xbfbfbbb8) at /home/timeless/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp:1070
#4  0x2a40ada5 in nsBox::Layout (this=0x86b1424, aState=@0xbfbfbbb8) at /home/timeless/mozilla/layout/xul/base/src/nsBox.cpp:1050
#5  0x2a4283e5 in nsBoxFrame::Reflow (this=0x86b13ec, aPresContext=0x8625800, aDesiredSize=@0xbfbfbdec, aReflowState=@0xbfbfbd34, aStatus=@0xbfbfc07c)
    at /home/timeless/mozilla/layout/xul/base/src/nsBoxFrame.cpp:998
#6  0x2a2ad34a in nsGfxScrollFrame::Reflow (this=0x86b13ec, aPresContext=0x8625800, aDesiredSize=@0xbfbfbdec, aReflowState=@0xbfbfbd34,
    aStatus=@0xbfbfc07c) at /home/timeless/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp:777
#7  0x2a28f810 in nsContainerFrame::ReflowChild (this=0x86b1130, aKidFrame=0x86b13ec, aPresContext=0x8625800, aDesiredSize=@0xbfbfbdec,
    aReflowState=@0xbfbfbd34, aX=0, aY=0, aFlags=0, aStatus=@0xbfbfc07c) at /home/timeless/mozilla/layout/html/base/src/nsContainerFrame.cpp:782
#8  0x2a324dd5 in ViewportFrame::Reflow (this=0x86b1130, aPresContext=0x8625800, aDesiredSize=@0xbfbfc028, aReflowState=@0xbfbfbf70, aStatus=@0xbfbfc07c)
    at /home/timeless/mozilla/layout/html/base/src/nsViewportFrame.cpp:573
#9  0x2a2f107d in PresShell::ResizeReflow (this=0x8625c00, aWidth=0, aHeight=6678) at /home/timeless/mozilla/layout/html/base/src/nsPresShell.cpp:2810
#10 0x2a2ff599 in PresShell::ResizeReflow (this=0x8625c00, aView=0x8621b80, aWidth=0, aHeight=6678)
    at /home/timeless/mozilla/layout/html/base/src/nsPresShell.cpp:6131
#11 0x2a6ace07 in nsViewManager::SetWindowDimensions (this=0x861f500, aWidth=0, aHeight=6678) at /home/timeless/mozilla/view/src/nsViewManager.cpp:584
#12 0x2a6b0c5a in nsViewManager::DispatchEvent (this=0x861f500, aEvent=0xbfbfc3e0, aStatus=0xbfbfc264)
    at /home/timeless/mozilla/view/src/nsViewManager.cpp:1670
#13 0x2a6a1906 in HandleEvent (aEvent=0xbfbfc3e0) at /home/timeless/mozilla/view/src/nsView.cpp:80
#14 0x29ba77c8 in nsWidget::DispatchEvent (this=0x8620400, aEvent=0xbfbfc3e0, aStatus=@0xbfbfc354)
    at /home/timeless/mozilla/widget/src/gtk/nsWidget.cpp:1406
#15 0x29ba7359 in nsWidget::DispatchWindowEvent (this=0x8620400, event=0xbfbfc3e0) at /home/timeless/mozilla/widget/src/gtk/nsWidget.cpp:1294
#16 0x29ba55ca in nsWidget::OnResize (this=0x8620400, event=0xbfbfc3e0) at /home/timeless/mozilla/widget/src/gtk/nsWidget.cpp:526
#17 0x29bb2287 in nsWindow::Resize (this=0x8620400, aWidth=1, aHeight=1, aRepaint=1) at /home/timeless/mozilla/widget/src/gtk/nsWindow.cpp:2522
#18 0x2a6a2c4c in nsView::SetDimensions (this=0x8621b80, aRect=@0xbfbfc508, aPaint=1) at /home/timeless/mozilla/view/src/nsView.cpp:530
#19 0x2a6acdca in nsViewManager::SetWindowDimensions (this=0x861f500, aWidth=0, aHeight=6678) at /home/timeless/mozilla/view/src/nsViewManager.cpp:578
#20 0x2a6b0c5a in nsViewManager::DispatchEvent (this=0x861f500, aEvent=0xbfbfc7e0, aStatus=0xbfbfc664)
    at /home/timeless/mozilla/view/src/nsViewManager.cpp:1670
#21 0x2a6a1906 in HandleEvent (aEvent=0xbfbfc7e0) at /home/timeless/mozilla/view/src/nsView.cpp:80
#22 0x29ba77c8 in nsWidget::DispatchEvent (this=0x8620400, aEvent=0xbfbfc7e0, aStatus=@0xbfbfc754)
    at /home/timeless/mozilla/widget/src/gtk/nsWidget.cpp:1406
#23 0x29ba7359 in nsWidget::DispatchWindowEvent (this=0x8620400, event=0xbfbfc7e0) at /home/timeless/mozilla/widget/src/gtk/nsWidget.cpp:1294
#24 0x29ba55ca in nsWidget::OnResize (this=0x8620400, event=0xbfbfc7e0) at /home/timeless/mozilla/widget/src/gtk/nsWidget.cpp:526

i'm filing because i have a patch..

Updated

17 years ago
Keywords: crash
(Assignee)

Comment 1

17 years ago
Created attachment 73862 [details] [diff] [review]
check for null scrollbars...
(Assignee)

Comment 2

17 years ago
ben, would you review this patch?
Assignee: ben → timeless

Comment 3

17 years ago
Is this just some wallpaper?  Maybe you should investigate why the scrollbar is
null in the first place.

Comment 5

16 years ago
Marking NEW not sure why this patch has been sitting around.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: crash switching from modern to wood → [PATCH] crash switching from modern to wood

Comment 6

16 years ago
Clearly the scrollbox shouldn't be null, so if you get there with a null
scrollbox something is wrong, and you're not gonna solve it by null-checking, IMO.

How about investigating the real cause?
Comment on attachment 73862 [details] [diff] [review]
check for null scrollbars...

sr=bzbarsky if you add an assertion that the scrollbarbox is not null. 
Hopefully that will motivate people to investigate and figure out the root
problem.
Attachment #73862 - Flags: superreview+
(Assignee)

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 77716 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.