Closed Bug 1304008 Opened 3 years ago Closed 3 years ago

Remove obsolete -moz-mac-lion-theme media query after bug 1302937

Categories

(Thunderbird :: Theme, defect)

All
macOS
defect
Not set

Tracking

(thunderbird50 unaffected, thunderbird51 fixed, thunderbird52 fixed)

RESOLVED FIXED
Thunderbird 52.0
Tracking Status
thunderbird50 --- unaffected
thunderbird51 --- fixed
thunderbird52 --- fixed

People

(Reporter: Paenglab, Assigned: Paenglab)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 1302937 landed and we need to remove the -moz-mac-lion-theme media query.
Attached patch no-moz-mac-lion-theme.patch (obsolete) — Splinter Review
Not yet tested.

Aleth, if you have time, could you test this patch? I can test only this evening and I have only OS X 10.11 where I can test this (except naturally Win/Linux for regression check).
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8792867 - Flags: feedback?(aleth)
(In reply to Richard Marti (:Paenglab) from comment #1)
> Aleth, if you have time, could you test this patch? I can test only this
> evening and I have only OS X 10.11 where I can test this (except naturally
> Win/Linux for regression check).

I only have 10.11 as well. I don't see any obvious errors either before or after the patch.
Comment on attachment 8792867 [details] [diff] [review]
no-moz-mac-lion-theme.patch

Review of attachment 8792867 [details] [diff] [review]:
-----------------------------------------------------------------

Btw the naming of the svg files is a bit confusing, as they are named -osx but are actually not used on >=Yosemite. Maybe something like -osxlion would be better?
Now using -osxlion for the < Yosemite OS X svg files. Made also a nicer alignment in mail/themes/osx/jar.mn
Attachment #8792867 - Attachment is obsolete: true
Attachment #8792867 - Flags: feedback?(aleth)
Attachment #8792996 - Flags: review?(philipp)
Attachment #8792996 - Flags: review?(aleth)
Attachment #8792996 - Flags: review?(philipp) → review+
Attachment #8792996 - Flags: review?(aleth) → review+
https://hg.mozilla.org/comm-central/rev/2d0ea2b8de0f
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 52.0
Minor drive-by comment: Since we don't support anything below 10.9, you could name the pre-yosemite files "-osxmavericks :-)
Comment on attachment 8792996 [details] [diff] [review]
no-moz-mac-lion-theme.patch

[Approval Request Comment]
Regression caused by (bug #): 1302937 which is in 51
User impact if declined: not correctly shown icons on OS X < 10.10
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low
Attachment #8792996 - Flags: approval-comm-aurora?
(In reply to Stefan [:stefanh] from comment #6)
> Minor drive-by comment: Since we don't support anything below 10.9, you
> could name the pre-yosemite files "-osxmavericks :-)

Ah yes, this was the name. But it's already landed and the actual naming is a bit shorter which makes it a bit easier aligning  in the jar.mn.
Attachment #8792996 - Flags: approval-comm-aurora? → approval-comm-aurora+
Aurora (TB 51):
https://hg.mozilla.org/releases/comm-aurora/rev/cdc8798091b3
BTW: Philipp uses r=philipp not r=Fallen ;-)
You need to log in before you can comment on or make changes to this bug.