Pref on the new console frontend in nightly

RESOLVED FIXED in Firefox 52

Status

enhancement
P1
normal
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: bgrins, Assigned: bgrins)

Tracking

unspecified
Firefox 52
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(4 attachments, 4 obsolete attachments)

Comment hidden (mozreview-request)
Will this pref ON the console only in nightly, or will it ride the trains too?
What are the missing features, bugs that must be fixed, perf regressions that must be addressed before this rides the trains?
This is only going to Pref the console on in Nightly. We will make an assessment from there about when it can ride the trains.

I'm planning to send out an email with this information, too, but here are the features that people might notice are missing.

In progress:

1. console.table (I'd say 50% chance it's resolved before we pref on)
2. some network message features (currently in progress)
3. some context menu features (e.g. save as global, this may be done before we pref on)

Backlog:
1. console.group
2. custom css for console messages
3. text searching is limited
4. the learn more link

I think that covers what people are likely to pick up on. There are other bugs and missing features which we are tracking. For example, reps don't currently handle Maps (so this is a bug in debugger and DOM panel as well). I'm also going through the current console's tests to see if we've missed features and potential bugs. Unfortunately we can't run many of these tests against the current frontend because the tests relied to heavily on an architecture that we didn't want to replicate. That work will continue after we've turned it on in nightly.

As far as performance regressions go, we don't have good data on that yet. Brian tried a Talos run, but Talos is not currently working with the new front end. Brian plans to address this, and we have that as one of the blockers for turning on in nightly.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee

Comment 10

3 years ago
New try push that makes jsterm.execute return the resulting dom node which should fix some tests: https://treeherder.mozilla.org/#/jobs?repo=try&revision=0b5e8263c352
Assignee

Updated

3 years ago
Blocks: 1304794
Assignee

Updated

3 years ago
Depends on: 1304804
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee

Updated

3 years ago
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Assignee

Updated

3 years ago
Depends on: 1306124
Assignee

Updated

3 years ago
Attachment #8793058 - Attachment is obsolete: true
Attachment #8793058 - Flags: review?(lclark)
Assignee

Updated

3 years ago
Attachment #8793059 - Attachment is obsolete: true
Attachment #8793059 - Flags: review?(lclark)
Assignee

Updated

3 years ago
Attachment #8793574 - Attachment is obsolete: true
Attachment #8793574 - Flags: review?(lclark)
Assignee

Updated

3 years ago
Attachment #8793575 - Attachment is obsolete: true
Attachment #8793575 - Flags: review?(lclark)
Assignee

Updated

3 years ago
Attachment #8795861 - Attachment is obsolete: true
Attachment #8795861 - Flags: review?(lclark)
Assignee

Updated

3 years ago
Depends on: 1291815
Assignee

Updated

3 years ago
Depends on: 1306780
Assignee

Updated

3 years ago
Depends on: 1307198
Assignee

Updated

3 years ago
Depends on: 1307239
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee

Updated

3 years ago
Attachment #8795862 - Attachment is obsolete: true
Attachment #8795862 - Flags: review?(lclark)
Assignee

Comment 21

3 years ago
I hope this patch should fix the jsterm.execute test failures.  Here's a try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=1d2fa38543da2adc871a94f7739afc55a212be65
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 24

3 years ago
mozreview-review
Comment on attachment 8793059 [details]
Bug 1304178 - Run less code on startup of new console frontend;

https://reviewboard.mozilla.org/r/79872/#review81808
Attachment #8793059 - Flags: review?(lclark) → review+

Comment 25

3 years ago
mozreview-review
Comment on attachment 8793574 [details]
Bug 1304178 - Reset the splitconsole pref after every test to make sure it gets cleaned up;

https://reviewboard.mozilla.org/r/80288/#review81810
Attachment #8793574 - Flags: review?(lclark) → review+

Comment 26

3 years ago
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/8aee9efaa33d
Return a promise from dispatchMessageAdd to support jsterm.execute callback for tests;r=linclark
https://hg.mozilla.org/integration/fx-team/rev/b95cb4a4e4f1
Remove the context menu in new webconsole frontend;r=linclark
https://hg.mozilla.org/integration/fx-team/rev/ad324639bfae
Pref on the new console frontend in nightly;r=linclark

Comment 27

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8aee9efaa33d
https://hg.mozilla.org/mozilla-central/rev/b95cb4a4e4f1
https://hg.mozilla.org/mozilla-central/rev/ad324639bfae
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52

Comment 28

3 years ago
Backout by philringnalda@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/c7d62e6d052c
Backed out changeset ad324639bfae for slowing down debugger tests enough to make their Linux32 debug test chunks exceed the 80 minute limit
Backed out the pref flip in https://hg.mozilla.org/mozilla-central/rev/c7d62e6d052c5d2638b08d480a720254ea09ff2d

You have to look at it with whatever the opposite of rose-colored glasses is, orange-colored glasses maybe, but the linux32 debug in https://treeherder.mozilla.org/#/jobs?repo=fx-team&group_state=expanded&filter-searchStr=linux%20debug%20devtools&tochange=ad324639bfaeba6d7be3b732295b6a27d0c54e0a&fromchange=47615f092e09d8d37d883ca72e35891b242a5d4a tells why. Debugger tests are basically permaorange with bug 1304778, that was the base state, but then this landing made them even slower, so that entirely too often they run over the 80 minute maximum time for the chunk.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 52 → ---
Oh, and I keep forgetting, but the slowdown also ran Win7 debug over the maxtime several times, it's just a lot easier to miss because it wasn't as frequent and harness bugs make a maxtime exceeded (which kills the entire run before it finishes, and is thus kind of a big deal) orange instead of the red it's supposed to be.
Assignee

Comment 31

3 years ago
Sorry about that, looking into it
Assignee

Comment 32

3 years ago
I have a promising looking try push that incorporates my change in bug 1304778: https://treeherder.mozilla.org/#/jobs?repo=try&revision=db68ac1694e1
Depends on: 1304778
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 37

3 years ago
mozreview-review
Comment on attachment 8798601 [details]
Bug 1304178 - Use a different node to scroll in old and new frontends;

https://reviewboard.mozilla.org/r/84016/#review82614
Attachment #8798601 - Flags: review?(lclark) → review+

Comment 38

3 years ago
mozreview-review
Comment on attachment 8798602 [details]
Bug 1304178 - Pref on the new console frontend in nightly;

https://reviewboard.mozilla.org/r/84018/#review82616
Attachment #8798602 - Flags: review?(lclark) → review+
Assignee

Comment 41

3 years ago
Looking much better, going to push this new series

Comment 42

3 years ago
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/fc10ed008963
Run less code on startup of new console frontend;r=linclark
https://hg.mozilla.org/integration/fx-team/rev/25c0e7b74658
Reset the splitconsole pref after every test to make sure it gets cleaned up;r=linclark
https://hg.mozilla.org/integration/fx-team/rev/72626ccc008c
Use a different node to scroll in old and new frontends;r=linclark
https://hg.mozilla.org/integration/fx-team/rev/a5510966f80b
Pref on the new console frontend in nightly;r=linclark

Comment 43

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fc10ed008963
https://hg.mozilla.org/mozilla-central/rev/25c0e7b74658
https://hg.mozilla.org/mozilla-central/rev/72626ccc008c
https://hg.mozilla.org/mozilla-central/rev/a5510966f80b
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Depends on: 1309483
fetch('http://ftp.mozilla.org/pub/firefox/nightly/2016/10/2016-10-01-03-04-30-mozilla-central/')
.then(response => response.text())
.then(data => {
  console.log(data);
})

This snippet used to work (data was not empty) before this change, doesn't work anymore now (data is empty).

Setting `devtools.webconsole.new-frontend-enabled` to false fixes the issue.
Depends on: 1310630
Depends on: 1311915
Depends on: 1312261
I'm removing dev-doc-needed from this bug because we should document the new console frontend when it lands in Dev Edition, not Nightly.
Keywords: dev-doc-needed

Updated

2 years ago
Depends on: 1326937
Depends on: 1347986

Updated

a year ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.