tb dropped 1-occurrence appts, recurring still remains

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
a year ago
8 months ago

People

(Reporter: Jim Michaels, Unassigned)

Tracking

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

put in doctor's appt and other appts, hoping to rely on tb's appt-making abilities.
put in recurring appts.


Actual results:

1-time appts do not show or popup.
recurring appts popup and do not go away from list until dismissed, and so "pile up" in the list.


Expected results:

1-time appts should popup and not leave the list until dismissed, and "pile up" until each is dismissed.
recurring appts should only show once in list per recurring appt, not per recurrence, and passed appt date should be shown. when recurrence starts again and is passed, should show up in list again.
(Reporter)

Comment 1

a year ago
my 1-occurrence appts also disappeared at random seeming times from tb.

Updated

a year ago
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 45 Branch → unspecified

Comment 2

a year ago
Jim, on which version of TB/Lightning are you? Do you see any messages in the error console?
Flags: needinfo?(jmichae3)
(Reporter)

Comment 3

a year ago
45.3.0

Could not read chrome manifest 'file:///C:/Program%20Files/Mozilla%20Thunderbird/chrome.manifest'.

Could not read chrome manifest 'jar:file:///C:/Program%20Files/Mozilla%20Thunderbird/extensions/%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D.xpi!/chrome.manifest'.

While creating services from category 'profile-after-change', could not create service for entry 'Sapi Speech Synth', contract ID '@mozilla.org/synthsapi;1'

Timestamp: 9/20/2016 6:20:21 PM
Warning: Unknown property 'grid-auto-columns'.  Declaration dropped.
Source File: resource://gre-resources/ua.css
Line: 175, Column: 19
Source Code:
  grid-auto-columns: inherit;

Timestamp: 9/20/2016 6:20:21 PM
Warning: Unknown property 'grid-auto-rows'.  Declaration dropped.
Source File: resource://gre-resources/ua.css
Line: 176, Column: 16
Source Code:
  grid-auto-rows: inherit;

Timestamp: 9/20/2016 6:20:21 PM
Warning: Unknown property 'grid-auto-flow'.  Declaration dropped.
Source File: resource://gre-resources/ua.css
Line: 177, Column: 16
Source Code:
  grid-auto-flow: inherit;

Timestamp: 9/20/2016 6:20:21 PM
Warning: Unknown property 'grid-column-gap'.  Declaration dropped.
Source File: resource://gre-resources/ua.css
Line: 178, Column: 17
Source Code:
  grid-column-gap: inherit;

Timestamp: 9/20/2016 6:20:21 PM
Warning: Unknown property 'grid-row-gap'.  Declaration dropped.
Source File: resource://gre-resources/ua.css
Line: 179, Column: 14
Source Code:
  grid-row-gap: inherit;

Timestamp: 9/20/2016 6:20:21 PM
Warning: Unknown property 'grid-template-areas'.  Declaration dropped.
Source File: resource://gre-resources/ua.css
Line: 180, Column: 21
Source Code:
  grid-template-areas: inherit;

Timestamp: 9/20/2016 6:20:21 PM
Warning: Unknown property 'grid-template-columns'.  Declaration dropped.
Source File: resource://gre-resources/ua.css
Line: 181, Column: 23
Source Code:
  grid-template-columns: inherit;

Timestamp: 9/20/2016 6:20:21 PM
Warning: Unknown property 'grid-template-rows'.  Declaration dropped.
Source File: resource://gre-resources/ua.css
Line: 182, Column: 20
Source Code:
  grid-template-rows: inherit;

Timestamp: 9/20/2016 6:20:23 PM
Warning: Use of Mutation Events is deprecated. Use MutationObserver instead.
Source File: chrome://calendar/content/widgets/calendar-widgets.xml
Line: 495

Timestamp: 9/20/2016 6:20:25 PM
Error: TypeError: tab is undefined
Source File: chrome://messenger/content/tabmail.xml
Line: 1072

Timestamp: 9/20/2016 6:20:29 PM
Error: TypeError: this.tree is null
Source File: chrome://calendar/content/calendar-unifinder.js
Line: 513

Timestamp: 9/20/2016 6:20:36 PM
Warning: Unknown property 'mso-table-lspace'.  Declaration dropped.
Source File: about:blank
Line: 61, Column: 20
Source Code:
    mso-table-lspace: 0pt;

Timestamp: 9/20/2016 6:20:36 PM
Warning: Unknown property 'mso-table-rspace'.  Declaration dropped.
Source File: about:blank
Line: 62, Column: 20
Source Code:
    mso-table-rspace: 0pt;

Timestamp: 9/20/2016 6:20:36 PM
Warning: Error in parsing value for 'float'.  Declaration dropped.
Source File: about:blank
Line: 136, Column: 8
Source Code:
  float:

Timestamp: 9/20/2016 6:20:36 PM
Warning: Unexpected end of file while searching for closing } of declaration block.  Unexpected end of file while searching for end of @media, @supports or @-moz-document rule.  Unexpected end of file while searching for '}'.
Source File: about:blank
Line: 136, Column: 8
Source Code:
  float:

Timestamp: 9/20/2016 6:20:56 PM
Error: uncaught exception: 2147746065
Source File: resource:///modules/activity/autosync.js
Line: 210

1474421061662	addons.update-checker	WARN	Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property

1474421061721	addons.update-checker	WARN	Update manifest for thunderbird-hotfix@mozilla.org did not contain an updates property

Timestamp: 9/21/2016 6:44:25 AM
Warning: Unknown property 'mso-table-lspace'.  Declaration dropped.
Source File: about:blank
Line: 61, Column: 20
Source Code:
    mso-table-lspace: 0pt;

Timestamp: 9/21/2016 6:44:25 AM
Warning: Unknown property 'mso-table-rspace'.  Declaration dropped.
Source File: about:blank
Line: 62, Column: 20
Source Code:
    mso-table-rspace: 0pt;

1474507580865	addons.update-checker	WARN	Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property

1474507580920	addons.update-checker	WARN	Update manifest for thunderbird-hotfix@mozilla.org did not contain an updates property
Flags: needinfo?(jmichae3)
(In reply to Jim Michaels from comment #0)
> 1-time appts should popup and not leave the list until dismissed, and "pile
> up" until each is dismissed.
This should be the case. If you close the window they are snoozed for a while and eventually come back. 


> recurring appts should only show once in list per recurring appt, not per
> recurrence, and passed appt date should be shown. when recurrence starts
> again and is passed, should show up in list again.
This is currently by design, recurring instances are allowed to dismiss separately and therefore show up more than once.


It sounds like the behavior you are seeing is mostly by design. If I have misunderstood things please explain in more detail.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

8 months ago
no, I mean they DON'T come back. it didn't get onto the server (IMAP), or it didn't get file permission or something I don't know.
(Reporter)

Comment 6

8 months ago
this is why I dropped tb. I need task lists that are /stable/, especially not disappearing for "a while" is unacceptable (I did not tell it to snooze!).
The alarm window is not a task list, if you need a task list then please use the task tab. Calendar items are not saved on IMAP servers, I'm not quite sure how to help here.
You need to log in before you can comment on or make changes to this bug.