Closed Bug 1304277 Opened 6 years ago Closed 6 years ago

[e10s] Uploading File to Amazon s3 on the client is causing browser to crash. Started in version 47.0

Categories

(Core :: Networking, defect)

49 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1167730
Tracking Status
e10s ? ---

People

(Reporter: trevordowdle, Unassigned)

Details

(Keywords: regression, Whiteboard: [necko-active])

Attachments

(1 file)

Attached file Info.rtf
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36

Steps to reproduce:

Use getUserMedia to record video/audio (8 seconds minimum) - Take the blob file and upload it to Amazon S3.

The application is a Meteor application and I am using the meteor-slingshot package to upload the file to S3.




Actual results:

As soon as I pass the blob file over to the upload method the browser CRASHES.


Expected results:

The file should upload in the browser.  

This actually worked great in 46.0b9 but stopped working in 47.0.

Also of note: If I install 46.0b9 and after successfully uploading a blob file in my application, I apply the update to 49.0, then I can upload without crashing in 49.0.

But If instead I install 46.0b9 and don't upload a file before updating to 49.0 then 49.0 crashes during the upload.

See:

https://crash-stats.mozilla.com/report/index/45ea2f47-c909-471e-893b-f73e22160921

https://crash-stats.mozilla.com/report/index/5e9c0818-d3e8-45d7-8a72-d72302160921
Do does it work with FF49 and a new profile? If yes, just update your Firefox version, because FF46 is EOLed.

If the rash is still reproducible with FF49, could you provide a live testcase, please.
Flags: needinfo?(trevordowdle)
(In reply to Loic from comment #1)
> Do does it work with FF49 and a new profile? If yes, just update your
> Firefox version, because FF46 is EOLed.
> 
> If the rash is still reproducible with FF49, could you provide a live
> testcase, please.

I wanted to test that,

So I attempted a clean install of FF49 last night to test it and I got the following error when trying to open Firefox:

"Firefox" is damaged and can’t be opened. You should move it to the Trash.

See image: https://www.dropbox.com/s/9cjeysbnw1gt3wt/Screen%20Shot%202016-09-21%20at%2010.32.33%20AM.png?dl=0

I am on a macbook pro and am getting the download link from:  https://www.mozilla.org/en-US/firefox/new/?scene=2

I'm not sure if this is an issue with my operating system, or with the download file itself..  But I can open other versions of Firefox directly from the install file such as Firefox 47.0.dmg

Please advise.
Component: General → Networking
looks like an e10s serialization thing
Flags: needinfo?(jduell.mcbugs)
I was able to clean install FF49 successfully after restarting my computer.  The error seems to creep up through uninstalling and reinstalling different versions of Firefox.  A restart fixes it.

The issue is reproducible in FF49.

I want to do some further testing to solidify my findings, however through 3-4 testing iterations this is what i've found.

FF46 - No Crash
FF47 - Crash
FF48 - No Crash
FF49 - Crash

Note: I ran into some issues where if I was on 46 and I went to Firefox-About, downloaded the latest update and then hit refresh.  Then tried to upload a blob file it wouldn't crash in FF49, however I think it was just a hybrid thing between FF46 and FF49 because if I completely shut down Firefox and re opened it then it crashed in FF49.  For this reason I have been working with just clean installs and been avoiding the auto update to switch between versions..

I will send out instructions on how to reproduce, including a live test case where you can try it.
This sounds like bug 1167730 as well.
Steps to reproduce with testcase

The test case involves using a website called boldvue.com, I have only developed/tested this website on a Macbook Pro, so a macbook or something similar would be ideal.

1.  Install a clean version of FF49
2.  Navigate to www.boldvue.com
3.  In the top right click Log In
4.  Where it shows Email Address/Password you can use the following credentials test@tester.com and joejoe for the password.
5.  Once logged in navigate to www.boldvue.com/record or click the green "Practice A Question" button at the top of the screen.
6.  Scroll down, click and type into both the Enter Role and Enter Question fields below.
7.  After text has been entered into both field the record button should turn red, click it.
8.  This will start a count down and after 3 seconds start recording - record for at least 10 seconds to be safe.
9.  Click the record button again to stop recording.
10. Here you can playback your recording with the Play button on the left side, the right side has a Publish button - click it.
11.  Here you specify whether you want your video to be public or private, you can select Private if you like, in case the upload doesn't crash and your video actually gets published on the site.
12.  After selecting Private, all that's left to do is click on the Public text or button in the bottom right.
13.  Firefox should crash.
14.  Happy debugging!

Let me know if you have any questions or issues.

Thanks
Sorry had a typo in step 12 - should say "click on the Publish text" not Public 

12.  After selecting Private, all that's left to do is click on the "Publish" text or button in the bottom right.
I'm able to reproduce the crash with e10s enabled, in old and next versions of Firefox.
https://crash-stats.mozilla.com/report/index/94f88c8f-23b4-4551-a01d-747b92160923

Maybe a dupe of bug 1167730.
tracking-e10s: --- → ?
Component: Networking → IPC
Depends on: 1167730
Summary: Uploading File to Amazon s3 on the client is causing browser to crash. Started in version 47.0 → [e10s] Uploading File to Amazon s3 on the client is causing browser to crash. Started in version 47.0
Still a networking bug.
Component: IPC → Networking
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Whiteboard: [necko-active]
This almost has to be a dup of bug 1167730.  We need to find a fix for that ASAP since we're shipping e10s.  I'd suggest duping this one to that.
bug 1167730 has been fixed, it should be in the nightly of Tuesday.
Trevor:  Could you download a nightly firefox build tomorrow and see if the issue is fixed for you?
Flags: needinfo?(jduell.mcbugs)
Will do.  Thank you
Was able to successfully upload in 52.0a1

Looks like it's fixed!  Thanks
Let's dupe so.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(trevordowdle)
Resolution: --- → DUPLICATE
No longer depends on: 1167730
You need to log in before you can comment on or make changes to this bug.