XUL browser element does not support Flash plugin when e10s is enabled

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: belaviyo, Unassigned)

Tracking

({flashplayer, multiprocess})

48 Branch
flashplayer, multiprocess
Points:
---

Firefox Tracking Flags

(e10s?)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160817112116

Steps to reproduce:

When e10s is enabled, XUL browser element cannot display flash content

Example:

<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>
<window id="yourwindow" xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul" xmlns:html="http://www.w3.org/1999/xhtml" xmlns:h="http://www.w3.org/1999/xhtml">
<browser flex="1" src="https://helpx.adobe.com/flash-player.html" type="content" style="border: 1px red solid;"/>
</window>


Actual results:

Open this XUL window when e10s is enabled. The flash part of the page is just grayed out


Expected results:

Flash content should have been rendered like it does on a borwser tab
(Reporter)

Updated

2 years ago
Keywords: flashplayer, multiprocess
OS: Unspecified → All
Hardware: Unspecified → All
(Reporter)

Comment 1

2 years ago
Created attachment 8793203 [details]
Flash content is grayed out in e10s

Comment 2

2 years ago
Benjamin, as Mozilla wants to remove XUL progressively, is it a bug to fix?
tracking-e10s: --- → ?
Component: Untriaged → Plug-ins
Flags: needinfo?(benjamin)
Product: Firefox → Core

Comment 3

2 years ago
We explicitly chose not to support this because it would cause deadlocks between the various processes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(benjamin)
Resolution: --- → WONTFIX
(Reporter)

Comment 4

2 years ago
So this suggests that no panel based add-on can load pages with Flash elements on them?

Comment 5

2 years ago
That's basically correct. You could possible create a remote browser and load your content+Flash in that.
(Reporter)

Comment 6

2 years ago
`<browser src="http://www.google.com/" flex="1" remote="true" />` displays nothing.
`<browser src="http://www.google.com/" flex="1" remote="false"/>` works as expected.

Firefox 50.0a2; Mac OS.

Am I doing something wrong?
(Reporter)

Comment 7

2 years ago
:bsmedberg any comments on my previous post?

Comment 8

2 years ago
Please use NEEDINFO when asking me questions or I probably won't see them. I don't know much more about how exactly you'd embed a remote browser successfully. That's something you'd have to ask on a newsgroup, probably mozilla.dev.platform.
You need to log in before you can comment on or make changes to this bug.