Icons in the main menu, identity block and control center need more opacity in high-contrast mode and on Linux

RESOLVED FIXED in Firefox 51

Status

()

defect
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

(Blocks 1 bug, {access})

Trunk
Firefox 52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51+ fixed, firefox52 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Posted patch patch (obsolete) — Splinter Review
The transparency currently used on these icons is too high to satisfy accessibility requirements.
Attachment #8793264 - Flags: review?(jhofmann)
Blocks: 1304343
Comment on attachment 8793264 [details] [diff] [review]
patch

Review of attachment 8793264 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!

::: browser/themes/shared/jar.inc.mn
@@ +71,2 @@
>    skin/classic/browser/notification-icons.svg                  (../shared/notification-icons.svg)
> +* skin/classic/browser/tracking-protection-16.svg              (../shared/identity-block/tracking-protection-16.svg)

It looks like the changes in this file are only reordering, right?
Attachment #8793264 - Flags: review?(jhofmann) → review+
(In reply to Johann Hofmann [:johannh] from comment #1)
> Comment on attachment 8793264 [details] [diff] [review]
> patch
> 
> Review of attachment 8793264 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks good!
> 
> ::: browser/themes/shared/jar.inc.mn
> @@ +71,2 @@
> >    skin/classic/browser/notification-icons.svg                  (../shared/notification-icons.svg)
> > +* skin/classic/browser/tracking-protection-16.svg              (../shared/identity-block/tracking-protection-16.svg)
> 
> It looks like the changes in this file are only reordering, right?

No, I've added * which enables preprocessing for these files.
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7d6f520753a2
Increase opacity of icons in the main menu, identity block and control center in high-contrast mode and on Linux. r=jhofmann
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/efcbe1b8f73a
Backed out changeset 7d6f520753a2 for bustage on a CLOSED TREE
Looks like I need to remove Windows line endings from some SVG files. I don't understand why this was building locally on Linux, though.
Flags: needinfo?(dao+bmo)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ef2896b755b7
Increase opacity of icons in the main menu, identity block and control center in high-contrast mode and on Linux. r=jhofmann
Blocks: 1304708
https://hg.mozilla.org/mozilla-central/rev/ef2896b755b7
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
https://hg.mozilla.org/mozilla-central/rev/ef2896b755b7
Closed: 3 years ago3 years ago
[Tracking Requested - why for this release]:

51 introduced this regression which makes main menu icons harder to see.
Track 51+ as 51 introduced this regression.

Hi :dao,
Is this worth uplifting to 51?
Flags: needinfo?(dao+bmo)
Posted patch landed patchSplinter Review
Approval Request Comment
[Feature/regressing bug #]: bug 1022573 only got us halfway there, this patch basically completes the fix
[User impact if declined]: Icons in the main menu, identity block and control center hard to see in Windows high-contrast mode and in some cases on Linux
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: straightforward fix, low risk. This is easy to uplift now that we've already uplifted bug 1303291.
[String/UUID change made/needed]: none
Attachment #8793264 - Attachment is obsolete: true
Flags: needinfo?(dao+bmo)
Attachment #8797412 - Flags: approval-mozilla-aurora?
Comment on attachment 8797412 [details] [diff] [review]
landed patch

This patch polishes UI related to icon. Take it in 51 aurora.
Attachment #8797412 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 1329895
You need to log in before you can comment on or make changes to this bug.