Closed Bug 1304347 Opened 5 years ago Closed 5 years ago

Same frames being displayed repeatedly when playing any videos

Categories

(Core :: Graphics, defect, P3)

51 Branch
All
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1299860
Tracking Status
firefox49 --- unaffected
firefox50 --- unaffected
firefox51 --- disabled
firefox52 --- fixed

People

(Reporter: jya, Assigned: eflores)

References

()

Details

(Keywords: regression, Whiteboard: [gfx-noted])

STR:
- Disable multi-process (e10s0
- Play any videos (I used )

Results: the same frames are being displayed repeatedly over and over. You can see from of the new frames from time to time.

Expected: should not be showing the same frames over and over. 


Mozregression gives:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8ef9629d8f90d6507b1bad01146b14101de79174&tochange=30fa88c82366a358f412ca2cc3268142c8991f0d

setting layers.acceleration.disabled=true does fix the problem.

Could be a surface/texture lifecycle issue? We've had similar problems in the past with D3D where the surface was deleted too quickly.

With e10s active I can't reproduce the issue.

Someone on IRC mentioned that it was intermittent for them, however when opening a 2nd tab pointing to about:support then playback would then be bad.
This affects YouTube
this is nightly only, right?
Edwin, could you take a look?  Not a crash!
Flags: needinfo?(edwin)
Priority: -- → P3
Whiteboard: [gfx-noted]
I first reproduced it at the time nightly was 51. so it will be on aurora now
See Also: → 1299860
See Also: → 1299588
Duplicate of this bug: 1299588
Version: unspecified → 51 Branch
Assignee: nobody → edwin
Flags: needinfo?(edwin)
I can't reproduce this at the moment.

The two hardware descriptions in bug 1299588 both mention AMD Radeon (Caicos and Juniper) graphics cards. I wonder whether this is driver-specific.
Just as another data point, could you post your about:support, jya?
Flags: needinfo?(jyavenard)
Assuming bug 1299860 is the same issue, it's probably not hardware-specific given the gfx.info attachment there.
Flags: needinfo?(jyavenard)
Note that today it works just fine ! (no recompilation)
{
  "application": {
    "name": "Firefox",
    "osVersion": "Linux 4.8.0-040800rc6-generic",
    "version": "52.0a1",
    "buildID": "20160921190235",
    "userAgent": "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0",
    "safeMode": false,
    "updateChannel": "default",
    "supportURL": "https://support.mozilla.org/1/firefox/52.0a1/Linux/en-US/",
    "numTotalWindows": 1,
    "numRemoteWindows": 0,
    "remoteAutoStart": false,
    "autoStartStatus": 2
  },
  "modifiedPreferences": {
    "browser.cache.frecency_experiment": 2,
    "browser.cache.disk.smart_size.first_run": false,
    "browser.cache.disk.smart_size.use_old_max": false,
    "browser.cache.disk.capacity": 358400,
    "browser.cache.disk.filesystem_reported": 1,
    "browser.download.importedFromSqlite": true,
    "browser.places.smartBookmarksVersion": 8,
    "browser.sessionstore.upgradeBackup.latestBuildID": "20160921190235",
    "browser.startup.homepage_override.buildID": "20160921190235",
    "browser.startup.homepage_override.mstone": "52.0a1",
    "browser.tabs.remote.autostart.2": false,
    "browser.urlbar.lastSuggestionsPromptDate": 20160802,
    "browser.urlbar.maxRichResults": 12,
    "browser.urlbar.daysBeforeHidingSuggestionsPrompt": 0,
    "dom.apps.lastUpdate.buildID": "20160729214126",
    "dom.report_all_js_exceptions": true,
    "dom.push.userAgentID": "8248e999f6164519918216ba5f598c96",
    "dom.max_chrome_script_run_time": 0,
    "dom.apps.lastUpdate.mstone": "50.0a1",
    "dom.apps.reset-permissions": true,
    "extensions.lastAppVersion": "52.0a1",
    "media.gmp-manager.buildID": "20160921190235",
    "media.gmp.storage.version.observed": 1,
    "media.gmp-gmpopenh264.lastUpdate": 1471533140,
    "media.gmp-widevinecdm.lastUpdate": 1471927837,
    "media.gmp-gmpopenh264.version": "1.6",
    "media.gmp-gmpopenh264.abi": "x86_64-gcc3",
    "media.eme.enabled": true,
    "media.gmp-manager.lastCheck": 1474607516,
    "media.gmp-widevinecdm.version": "1.4.8.903",
    "media.mediasource.mp4.enabled": false,
    "media.gmp-widevinecdm.abi": "x86_64-gcc3",
    "network.cookie.prefsMigrated": true,
    "network.predictor.cleaned-up": true,
    "places.database.lastMaintenance": 1474080774,
    "places.history.expiration.transient_current_max_pages": 122334,
    "plugin.importedState": true,
    "plugin.disable_full_page_plugin_for_types": "application/pdf",
    "plugin.state.flash": 0,
    "services.sync.declinedEngines": "",
    "services.sync.lastPing": 1474607477,
    "services.sync.lastSync": "Fri Sep 23 2016 15:12:57 GMT+1000 (AEST)",
    "services.sync.numClients": 2,
    "services.sync.engine.prefs.modified": false,
    "storage.vacuum.last.places.sqlite": 1474080774,
    "storage.vacuum.last.index": 1
  },
  "lockedPreferences": {},
  "javaScript": {
    "incrementalGCEnabled": true
  },
  "accessibility": {
    "isActive": false,
    "forceDisabled": 0
  },
  "libraryVersions": {
    "NSPR": {
      "minVersion": "4.13 Beta",
      "version": "4.13 Beta"
    },
    "NSS": {
      "minVersion": "3.27 Beta",
      "version": "3.27 Beta"
    },
    "NSSUTIL": {
      "minVersion": "3.27 Beta",
      "version": "3.27 Beta"
    },
    "NSSSSL": {
      "minVersion": "3.27 Beta",
      "version": "3.27 Beta"
    },
    "NSSSMIME": {
      "minVersion": "3.27 Beta",
      "version": "3.27 Beta"
    }
  },
  "userJS": {
    "exists": false
  },
  "crashes": {
    "submitted": [],
    "pending": 0
  },
  "sandbox": {
    "hasSeccompBPF": true,
    "hasSeccompTSync": true,
    "hasPrivilegedUserNamespaces": true,
    "hasUserNamespaces": true,
    "canSandboxContent": true,
    "canSandboxMedia": true,
    "contentSandboxLevel": 1
  },
  "extensions": [
    {
      "name": "about:media",
      "version": "2.4",
      "isActive": true,
      "id": "aboutmedia@gavinsharp.com"
    },
    {
      "name": "FlyWeb",
      "version": "1.0.0",
      "isActive": true,
      "id": "flyweb@mozilla.org"
    },
    {
      "name": "Form Autofill",
      "version": "1.0",
      "isActive": true,
      "id": "formautofill@mozilla.org"
    },
    {
      "name": "Multi-process staged rollout",
      "version": "1.2",
      "isActive": true,
      "id": "e10srollout@mozilla.org"
    },
    {
      "name": "Pocket",
      "version": "1.0.5",
      "isActive": true,
      "id": "firefox@getpocket.com"
    },
    {
      "name": "Web Compat",
      "version": "1.0",
      "isActive": true,
      "id": "webcompat@mozilla.org"
    },
    {
      "name": "Ubuntu Modifications",
      "version": "3.2",
      "isActive": false,
      "id": "ubufox@ubuntu.com"
    },
    {
      "name": "User-Agent Switcher",
      "version": "0.1.8",
      "isActive": false,
      "id": "jid1-kyxEAcWua7BEKq@jetpack"
    }
  ],
  "experiments": [],
  "graphics": {
    "numTotalWindows": 1,
    "numAcceleratedWindows": 1,
    "windowLayerManagerType": "OpenGL",
    "windowLayerManagerRemote": true,
    "supportsHardwareH264": "No",
    "currentAudioBackend": "pulse",
    "adapterDescription": "Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) ",
    "adapterVendorID": "Intel Open Source Technology Center",
    "adapterDeviceID": "Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) ",
    "adapterRAM": "",
    "adapterDrivers": "",
    "driverVersion": "3.0 Mesa 11.2.0",
    "driverDate": "",
    "webglRenderer": "Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) ",
    "webgl2Renderer": "Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) ",
    "info": {
      "AzureCanvasBackend": "skia",
      "AzureCanvasAccelerated": 0,
      "AzureFallbackCanvasBackend": "none",
      "AzureContentBackend": "skia",
      "CairoUseXRender": 0
    },
    "featureLog": {
      "features": [
        {
          "name": "HW_COMPOSITING",
          "description": "Compositing",
          "status": "available",
          "log": [
            {
              "type": "default",
              "status": "available"
            }
          ]
        },
        {
          "name": "OPENGL_COMPOSITING",
          "description": "OpenGL Compositing",
          "status": "available",
          "log": [
            {
              "type": "default",
              "status": "available"
            }
          ]
        }
      ],
      "fallbacks": []
    },
    "crashGuards": []
  }
}
Duplicate of this bug: 1302911
I have this bug with Firefox 50.0b1 and Nvidia closed driver 367.44 (GTX 680).
(In reply to Shmerl from comment #12)
> I have this bug with Firefox 50.0b1 and Nvidia closed driver 367.44 (GTX
> 680).

You enabled hardware layers I gather.
(In reply to Jean-Yves Avenard [:jya] from comment #13)
> (In reply to Shmerl from comment #12)
> > I have this bug with Firefox 50.0b1 and Nvidia closed driver 367.44 (GTX
> > 680).
> 
> You enabled hardware layers I gather.

Yep, I did.
I'm the guy who created 1302911

I thought this had cleared up after a Firefox and Mesa update but it's still rearing its head. 

firefox-nightly 52.0a1.20160923-1

The issues goes away in safe mode but I can't figure out what part of my normal setup that causes it.

e10s is off

My about:support

I don't have any Greasemonkey scripts running on YouTube (And this bug is affecting other HTML5 videos as well)

Application Basics
------------------

Name: Firefox
Version: 52.0a1
Build ID: 20160923030450
Update Channel: nightly
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
OS: Linux 4.8.0-rc6-g5924bbe
Multiprocess Windows: 0/1 (Disabled)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: checkCompatibility
Version: 1.3.1-signed.1-signed
Enabled: true
ID: check-compatibility@dactyl.googlecode.com

Name: FlyWeb
Version: 1.0.0
Enabled: true
ID: flyweb@mozilla.org

Name: Form Autofill
Version: 1.0
Enabled: true
ID: formautofill@mozilla.org

Name: Greasemonkey
Version: 3.9
Enabled: true
ID: {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

Name: Multi-process staged rollout
Version: 1.2
Enabled: true
ID: e10srollout@mozilla.org

Name: Open With
Version: 6.7.2
Enabled: true
ID: openwith@darktrojan.net

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: Reddit Enhancement Suite
Version: 5.0.2
Enabled: true
ID: jid1-xUfzOsOFlzSOXg@jetpack

Name: RedditNotifier
Version: 2.0.2.1-signed
Enabled: true
ID: jid1-jz0wH8To7NqwdQ@jetpack

Name: uBlock Origin
Version: 1.9.10
Enabled: true
ID: uBlock0@raymondhill.net

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Graphics
--------

Features
Compositing: OpenGL
Asynchronous Pan/Zoom: none
WebGL Renderer: ATI Technologies Inc. -- AMD Radeon (TM) RX 480 Graphics
WebGL2 Renderer: ATI Technologies Inc. -- AMD Radeon (TM) RX 480 Graphics
Hardware H264 Decoding: No
Audio Backend: pulse
GPU #1
Active: Yes
Description: ATI Technologies Inc. -- AMD Radeon (TM) RX 480 Graphics
Vendor ID: ATI Technologies Inc.
Device ID: AMD Radeon (TM) RX 480 Graphics
Driver Version: 4.5.13448 Compatibility Profile Context

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: none
CairoUseXRender: 0





Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 1
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.sessionstore.upgradeBackup.latestBuildID: 20160923030450
browser.startup.homepage_override.buildID: 20160923030450
browser.startup.homepage_override.mstone: 52.0a1
browser.tabs.remote.autostart.2: false
browser.tabs.warnOnClose: false
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 0
browser.urlbar.lastSuggestionsPromptDate: 20160810
dom.apps.lastUpdate.buildID: 20160623030210
dom.apps.lastUpdate.mstone: 50.0a1
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.checkCompatibility.45.0a: false
extensions.checkCompatibility.46.0a: false
extensions.checkCompatibility.47.0a: false
extensions.checkCompatibility.48.0a: false
extensions.checkCompatibility.49.0a: false
extensions.checkCompatibility.50.0a: false
extensions.checkCompatibility.51.0a: false
extensions.checkCompatibility.52.0a: false
extensions.checkCompatibility.nightly: false
extensions.lastAppVersion: 52.0a1
font.internaluseonly.changed: true
media.gmp-gmpopenh264.abi: x86_64-gcc3
media.gmp-gmpopenh264.lastUpdate: 1470794181
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20160923030450
media.gmp-manager.lastCheck: 1474824148
media.gmp.storage.version.observed: 1
media.webrtc.debug.aec_log_dir: /tmp
media.webrtc.debug.log_file: /tmp/WebRTC.log
network.cookie.prefsMigrated: true
network.dns.disablePrefetch: true
network.http.speculative-parallel-limit: 0
network.predictor.cleaned-up: true
network.prefetch-next: false
places.database.lastMaintenance: 1474348360
places.history.expiration.transient_current_max_pages: 122539
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.flash: 1
print.print_bgcolor: false
print.print_bgimages: false
print.print_duplex: 0
print.print_evenpages: true
print.print_in_color: true
print.print_margin_bottom: 0.5
print.print_margin_left: 0.5
print.print_margin_right: 0.5
print.print_margin_top: 0.5
print.print_oddpages: true
print.print_orientation: 0
print.print_page_delay: 50
print.print_paper_data: 0
print.print_paper_height: 11.00
print.print_paper_name: na_letter
print.print_paper_size_unit: 0
print.print_paper_width: 8.50
print.print_scaling: 1.00
print.print_shrink_to_fit: true
print.print_to_file: false
print.print_unwriteable_margin_bottom: 56
print.print_unwriteable_margin_left: 25
print.print_unwriteable_margin_right: 25
print.print_unwriteable_margin_top: 25
privacy.cpd.sessions: false
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.timeSpan: 3
services.sync.declinedEngines:
services.sync.engine.greasemonkey: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1474348359

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.13 Beta
Version in use: 4.13 Beta

NSS
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

NSSSMIME
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

NSSSSL
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

NSSUTIL
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

Experimental Features
---------------------

Sandbox
-------

Seccomp-BPF (System Call Filtering): true
Seccomp Thread Synchronization: true
User Namespaces: false
Content Process Sandboxing: true
Media Plugin Sandboxing: true
Content Process Sandbox Level: 1
Duplicate of this bug: 1305572
Edwin, Nical, is this being taken care of in another bug, or is this the bug for it?
Flags: needinfo?(nical.bugzilla)
Flags: needinfo?(edwin)
I am working on bug 1299860 which I think is the same issue.
Flags: needinfo?(nical.bugzilla)
Flags: needinfo?(edwin)
Should we dupe this over to bug 1299860 then?

(I filed the most recent duplicate here, when I was hitting this several times a day.  And now I know I've gone at least a few days without hitting this bug at all, which I think means it's indeed fixed [presumably by bug 1299860]. \o/  )
Flags: needinfo?(nical.bugzilla)
I, too, filed a bug about this, and I'm not seeing it any more in the latest nightly.
(In reply to Daniel Holbert [:dholbert] from comment #19)
> Should we dupe this over to bug 1299860 then?

Yes indeed
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(nical.bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1299860
You need to log in before you can comment on or make changes to this bug.