If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Simulate beta1 release builds by regularly merging aurora to jamun

RESOLVED WONTFIX

Status

Release Engineering
Release Automation
P3
normal
RESOLVED WONTFIX
a year ago
2 months ago

People

(Reporter: rail, Assigned: mtabara)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
To prevent "OMG Beta1" issues we should start regularly uplift aurora to jamun and run release builds.

We can use https://dxr.mozilla.org/mozilla-central/source/testing/mozharness/scripts/merge_day/gecko_migration.py with a config like https://dxr.mozilla.org/mozilla-central/source/testing/mozharness/configs/merge_day/aurora_to_beta.py

The script should be modified to skip any manipulation of the "from" repo, such as tagging in https://dxr.mozilla.org/mozilla-central/source/testing/mozharness/scripts/merge_day/gecko_migration.py#489-492, pushing https://dxr.mozilla.org/mozilla-central/source/testing/mozharness/scripts/merge_day/gecko_migration.py#182, etc. These actions should be configurable.

Also, it'd be great to separate pull and push URLs, so we pull using https:// (and the corresponding bundles) and push to ssh://.

Mihai volunteered, thank you!
(Reporter)

Updated

a year ago
Duplicate of this bug: 1291661
(Reporter)

Updated

7 months ago
Priority: -- → P3
(Assignee)

Comment 2

2 months ago
Found in triaging. Aurora is dead, long live Dawn!

https://github.com/mozilla/releasewarrior/blob/master/how-tos/setup-staging-release.md describes how to perform staging releases. We are now doing these as part of releaseduty. Closing this bug.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.