Closed Bug 1304484 Opened 3 years ago Closed 3 years ago

Interactive loaners fail to download "run-wizard" binary because vcs environment variables not set

Categories

(Taskcluster :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla52

People

(Reporter: ahal, Assigned: ahal)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

At some point downloading the "run-wizard" binary stopped working, I think because the vcs environment variables like GECKO_HEAD_REPOSITORY aren't being set.

I'll do some more digging and report back.
Looks like these env vars were removed as part of the patch in bug 1296397. Patch coming soon that adds them back (using the proper method in common.py).
Depends on: 1296397
I'll be PTO the rest of the week so feel free to autoland on my behalf if everything looks good.
Comment on attachment 8793523 [details]
Bug 1304484 - Add back gecko vcs environment variables for desktop-test tasks,

https://reviewboard.mozilla.org/r/80240/#review78896

::: taskcluster/taskgraph/transforms/tests/make_task_description.py:206
(Diff revision 1)
>      ]
>  
>      # If we have a source checkout, run mozharness from it instead of
>      # downloading a zip file with the same content.
>      if test['checkout']:
>          docker_worker_support_vcs_checkout(config, test, taskdesc)

Let's make this line unconditional instead. It performs a superset of what `docker_worker_add_gecko_vcs_env_vars` does.
Attachment #8793523 - Flags: review?(gps) → review-
Comment on attachment 8793523 [details]
Bug 1304484 - Add back gecko vcs environment variables for desktop-test tasks,

https://reviewboard.mozilla.org/r/80240/#review79712
Attachment #8793523 - Flags: review?(gps) → review+
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/edeed81829c1
Add back gecko vcs environment variables for desktop-test tasks, r=gps
https://hg.mozilla.org/mozilla-central/rev/edeed81829c1
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Duplicate of this bug: 1311386
You need to log in before you can comment on or make changes to this bug.