Easily avoidable yet fatal installation error

RESOLVED INVALID

Status

SeaMonkey
Installer
--
critical
RESOLVED INVALID
16 years ago
9 years ago

People

(Reporter: Matt Fago, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
BuildID:    0.9.9

If a user mistakenly executes the mozilla-installer-bin script instead of the
mozilla-installer script, the installation fails with the error:

"Fatal Error[-618]: Couldn't open xpistub library:

Ok, so this is a user error (althought the installation instructions are sparse
at best).

Nevertheless, why don't we make a _simple_ change that would eliminate this problem?

Simply change:

./mozilla-installer-bin

to:

./.mozilla-installer-bin

Is there any reason not to do this?

Yes, this _could_ be considered a duplicate of bug 107368, but it really should
be fixed!

Reproducible: Always
Steps to Reproduce:
1.download linux installer and unpack
2.run mozilla-installer-bin
3.

Actual Results:  Installer bombed

Expected Results:  Mozilla installed
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
The same thing happens with the built directory: mozilla, mozilla-bin and
run-mozilla.sh.  In fact, many programs use scripts to wrap their binaries.

I think you could make a much stronger argument for mentioning using the
installer in the README file that comes with the installer.  There are multiple
bugs that deal with the documentation, most notably bug 45863.
(Reporter)

Comment 2

16 years ago
Yes scripts are a common behavior, and putting the correction in the README
would help.

Nevertheless, wouldn't it be a simple and more complete fix to simply hide the
executable "mozilla-installer-bin" ?!

Just trying to make 1.0 seem more polished...

Updated

16 years ago
QA Contact: bugzilla → ktrina
Product: Browser → Seamonkey
Assignee: dveditz → nobody
QA Contact: ktrina → general
The linux installer is gone
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.