"Handler function threw an exception: TypeError: httpActivity.owner is null" spam

RESOLVED DUPLICATE of bug 1304752

Status

()

Firefox
Developer Tools: Netmonitor
P1
normal
RESOLVED DUPLICATE of bug 1304752
a year ago
a year ago

People

(Reporter: nmaier, Assigned: jsnajdr)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox52 affected)

Details

(Reporter)

Description

a year ago
On Nightly, I see a LOT of messages like so:

"Handler function threw an exception: TypeError: httpActivity.owner is null
Stack: NetworkMonitor.prototype._onResponseHeader@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/webconsole/network-monitor.js:1276:5
NetworkMonitor.prototype._dispatchActivity@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/webconsole/network-monitor.js:900:9
NetworkMonitor.prototype.observeActivity<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/webconsole/network-monitor.js:962:7
exports.makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:101:14
Line: 1276, column: 5"

While the "errors" itself don't seem to have any real side-effects, they spam the Browser Console, making it unresponsive and far less useful, basically DoSing the Browser Console.

In my case is likely to be caused by DownThemAll! setting up channels in a way the net-monitor code does not expect, but I think I saw these errors unrelated to DownThemAll! and triggered by toolkit and/or other add-on code I think.

STR:
- Install e.g. DownThemAll! and do some downloads
- See the Browser Console (error console) fill up with messages

https://dxr.mozilla.org/mozilla-central/rev/560b2c805bf7bebeb3ceebc495a81b2aa4c0c755/devtools/shared/webconsole/network-monitor.js#1254-1276
The code in question should make sure httpActivity.owner is not null (and only create that |request| objection when it isn't)
(Reporter)

Updated

a year ago
Depends on: 1304752
(Assignee)

Updated

a year ago
Assignee: nobody → jsnajdr
Priority: -- → P1
(Assignee)

Comment 1

a year ago
httpActivity.owner is only null because the function that was supposed to set if failed because of bug 1304752.
Status: NEW → RESOLVED
Last Resolved: a year ago
No longer depends on: 1304752
Resolution: --- → DUPLICATE
Duplicate of bug: 1304752
You need to log in before you can comment on or make changes to this bug.