Status

()

P3
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: cpeterson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Bobby says there are no big blockers for e10s: just a crash somewhere and, given that non-e10s is generally easier to debug, nobody has bothered to look into it.

Updated

2 years ago
Duplicate of this bug: 1288046
It seems stylo no longer crash on e10s. I guess it is fixed by bug 1298588 because IIRC previously I saw that the crash was on initialization of initial style struct.

Given it no longer crashes, I think we should start enabling tests on e10s as well.
Depends on: 1298588
But see bug 1328651, which is responsible for the fatal assertions on debug builds.
Depends on: 1328651
(In reply to Bobby Holley (:bholley) (busy with Stylo) from comment #3)
> But see bug 1328651, which is responsible for the fatal assertions on debug
> builds.

And per that bug, I think we should just disable the style context tree verifications (bug 1322568), since we have a whole different set of failures in e10s mode.
(Reporter)

Updated

2 years ago
Blocks: 1330412
No longer blocks: 1243581
We're now running stylo under e10s on try.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.