Closed Bug 1304814 Opened 3 years ago Closed 3 years ago

test_bug1295852.html | uncaught exception - TypeError: element.getAnimations is not a function at @http://mochi.test:8888/tests/dom/base/test/test_bug1295852.html:16:6

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: aryx, Assigned: heycam)

References

Details

Attachments

(1 file)

If mozilla-central gets run as beta in a simulation https://wiki.mozilla.org/Sheriffing/Uplift-Sim/Trunk-Beta , the following error occurs on Linux (taskcluster for x64, debug for x86):

https://treeherder.mozilla.org/logviewer.html#?job_id=27840137&repo=try

[task 2016-09-21T23:14:05.267318Z] 23:14:05     INFO -  173 INFO TEST-START | dom/base/test/test_bug1295852.html
[task 2016-09-21T23:14:05.338409Z] 23:14:05     INFO -  TEST-INFO | started process screentopng
[task 2016-09-21T23:14:06.827278Z] 23:14:06     INFO -  TEST-INFO | screentopng: exit 0
[task 2016-09-21T23:14:06.830935Z] 23:14:06     INFO -  174 INFO TEST-UNEXPECTED-FAIL | dom/base/test/test_bug1295852.html | uncaught exception - TypeError: element.getAnimations is not a function at @http://mochi.test:8888/tests/dom/base/test/test_bug1295852.html:16:6

The test likely assumes that web animations are always enabled, but they are only on Aurora and Nightly https://dxr.mozilla.org/mozilla-central/source/modules/libpref/init/all.js#2695
Assignee: nobody → cam
Status: NEW → ASSIGNED
Component: General → CSS Parsing and Computation
Comment on attachment 8794034 [details]
Bug 1304814 - Make test_bug1295852.html survive Web Animations being disabled.

https://reviewboard.mozilla.org/r/80616/#review79320

Looks good to me.
Attachment #8794034 - Flags: review?(boris.chiou) → review+
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/379da15420cb
Make test_bug1295852.html survive Web Animations being disabled. r=boris
https://hg.mozilla.org/mozilla-central/rev/379da15420cb
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Duplicate of this bug: 1306941
Comment on attachment 8794034 [details]
Bug 1304814 - Make test_bug1295852.html survive Web Animations being disabled.

Approval Request Comment
[Feature/regressing bug #]: bug 1295852
[User impact if declined]: -
[Describe test coverage new/current, TreeHerder]: -
[Risks and why]: -
[String/UUID change made/needed]: -
Attachment #8794034 - Flags: approval-mozilla-aurora?
Comment on attachment 8794034 [details]
Bug 1304814 - Make test_bug1295852.html survive Web Animations being disabled.

No need for approval, it's test-only.
Attachment #8794034 - Flags: approval-mozilla-aurora?
You need to log in before you can comment on or make changes to this bug.