Quick filter / advanced search do not work reliably

RESOLVED DUPLICATE of bug 1245532

Status

Thunderbird
Search
--
major
RESOLVED DUPLICATE of bug 1245532
a year ago
a year ago

People

(Reporter: trashcan4junk, Unassigned)

Tracking

45 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160818000000

Steps to reproduce:

Tried searching for a known term, messages with the term are not found, via quickfilter or "Search for messages" tool.


Actual results:

I can see the message, with the search term in the body, using either quick filter with body nor searching messages yields a result.


Expected results:

Search is basic functionality, I'd rather a slow, cumbersome search that works to anything.  Eager to understand why this is happening.  I've rebuilt the index multiple times, but have recently just shut it off and was going to use quick-filter although searches can take awhile, now I find that even it doesn't work reliably.
(Reporter)

Comment 1

a year ago
Created attachment 8793932 [details]
ss_thunderbird.png Shows term in the body of a message in Archives
(Reporter)

Comment 2

a year ago
Created attachment 8793934 [details]
ss_thunderbird_nr.png  Shows no result for the quick filter of that folder
(Reporter)

Comment 3

a year ago
Created attachment 8793935 [details]
ss_thunderbird_search.png Shows no result for full search of Archives
(Reporter)

Updated

a year ago
Severity: normal → major
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 4

a year ago
Account is an exchange IMAP account, domain based authentication.  Profile is on the local disk (symbolic link inside NFS share points to local .thunderbird configuration folder).
Please attach to the bug an .eml file of an actual message that fails.  Sanitize as needed.
Please don't confuse "Advanced Search" with "Gloda" (Global Database - https://developer.mozilla.org/en-US/docs/Mozilla/Thunderbird/gloda). I changed the summary accordingly.

Also note that quick search and advanced search use the same underlying technology.

Other than that, we know that there are plenty of search problems with body searches IMAP folders. Take a look here: Bug 1245532, bug 1251651 and also bug 519202.

You're bug report doesn't provide any new insight.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Summary: Quick filter / global search do not work reliably → Quick filter / advanced search do not work reliably
Duplicate of bug: 1245532
You need to log in before you can comment on or make changes to this bug.