Closed Bug 1304899 Opened 4 years ago Closed 4 years ago

[EME] Don't download Adobe Primetime CDM by default

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla52
Tracking Status
firefox52 --- verified

People

(Reporter: cpearce, Assigned: cpearce)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We should disable the Primetime CDM so that it isn't downloaded and installed by default. We still want to leave it "visible", so that it will appear disabled in the addons#plugins UI, and the user will be prompted to enable it if a site is encountered which tries to use Adobe Primetime EME.
Comment on attachment 8793983 [details]
Bug 1304899 - Don't download Adobe Primetime CDM by default.

https://reviewboard.mozilla.org/r/80552/#review79614
Attachment #8793983 - Flags: review?(ajones) → review+
Pushed by cpearce@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cdef8c0f10a3
Don't download Adobe Primetime CDM by default. r=kentuckyfriedtakahe
https://hg.mozilla.org/mozilla-central/rev/cdef8c0f10a3
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Flags: qe-verify+
I've reproduced the issue described in comment 0 using 52.0a1 old Nightly (Build Id: 20160922030437) and verified that the issues is fixed using Firefox 52.0a1 old Nightly (Build ID:20160927030200)after the patch landed, across platforms (macOS 10.12 and Windows 10 64bit). 

However I have noticed that on Firefox 52 beta 8 ( Build ID:20170220070057) Adobe Primetime CDM is not visible in the about:plugins and about:addons pages. 

Could you please tell me if Adobe Primetime CDM is included in the Widevine Content Decryption Module provided by Google Inc?
Flags: needinfo?(cpearce)
We removed Adobe Primetime from Firefox in 52. What you're seeing is expected.
Flags: needinfo?(cpearce)
Thank you Chris!
Based on my testing and comment 7 I think it’s safe to mark this as verified fixed since I already verified that the issue does not reproduce on a build after the patch landed Nightly 52.0a1(Build Id:20160927030200)even though in today's 52 beta 8 (Build Id:20170220070057) Adobe Primetime is completely removed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.