background-attachment fixed not works with transform value

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: rewwerse, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36

Steps to reproduce:

please see this example on jsfiddle - https://jsfiddle.net/r8ec20qL/

css value transform turn off background-attachment: fixed.
If you remove from css transform: translate3d(0,0,0) it starts to work.


Actual results:

background-attachment fixed starts to work as scroll


Expected results:

background should be fixed

Comment 1

2 years ago
Edge and Firefox seems to be same behavior.
IE11 and Chrome behave as the expected.
Component: Untriaged → Layout
Product: Firefox → Core
Whiteboard: [parity-Chrome][parity-IE]

Comment 2

2 years ago
[Tracking Requested - why for this release]: Regression since Firefox48
Status: UNCONFIRMED → NEW
status-firefox49: --- → wontfix
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox-esr45: --- → unaffected
tracking-firefox52: --- → ?
Ever confirmed: true
Keywords: regression
Version: 49 Branch → 48 Branch

Comment 3

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=26c4c6e4f701839d851f12861a77ac1dfa7a695a&tochange=8150c0a47bd7f0dc3b0f5b7fc47b685056579087

So, this is intentional change by Bug 735857 and CSS Spec Compliance.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox49: wontfix → ---
status-firefox50: affected → ---
status-firefox51: affected → ---
status-firefox52: affected → ---
status-firefox-esr45: unaffected → ---
tracking-firefox52: ? → ---
Keywords: regression
Resolution: --- → INVALID
Whiteboard: [parity-Chrome][parity-IE]
You need to log in before you can comment on or make changes to this bug.