Status

()

Core
SVG
RESOLVED DUPLICATE of bug 265894
11 months ago
11 months ago

People

(Reporter: Sascha Brawer, Unassigned, NeedInfo)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
Created attachment 8794240 [details]
firefox-svg-bug.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

Look at the attached HTML file in Firefox. Compare to Chrome and Safari.


Actual results:

Other than the other browsers, Firefox apparently fails to handle the scaleY(-1) in the CSS stylesheet for the SVG image in the HTML file. Firefox therefore cannot render the image correctly, so the letter appears flipped.


Expected results:

The scaleY(-1) should be respected, so the letter gets rendered in the upright position. Chrome v53.0.2785.116 and Safari v9.1.3 can both correctly render the file.
(Reporter)

Comment 1

11 months ago
Bug can be reproduced also in Firefox 49.0

Comment 2

11 months ago
Could you attach some screenshots of the rendering in FF/Chrome/Safari, please.
Component: Untriaged → SVG
Flags: needinfo?(sascha)
Product: Firefox → Core

Comment 3

11 months ago
It probably flips it twice, once for the root (which is what you expect) and once when the symbol becomes an svg element following the clone. This was possibly correct in SVG 1.1 but it certainly wrong in SVG 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265894
You need to log in before you can comment on or make changes to this bug.