Mozilla crashes when opening certain email messages [@ nsImapMailFolder::NormalEndMsgWriteStream]

VERIFIED DUPLICATE of bug 126987

Status

--
critical
VERIFIED DUPLICATE of bug 126987
17 years ago
14 years ago

People

(Reporter: harrij, Assigned: sspitzer)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9+) Gecko/20020312
BuildID:    2002031203

When trying to open certain messages from IMAP folder Mozilla crashes every
time. So far this only happens with two separate messages than contain .exe
attachment.

I've created .eml attachments for the crash causing emails

Reproducible: Always
Steps to Reproduce:
1.choose the offending message
2.double click to open it
3.Mozilla crash

Actual Results:  Mozilla crashes

Expected Results:  The message should have been opened normally.

Talkback ID's:
TB3980428G
TB3980387Z
TB3980355W
TB3979507Q
(Reporter)

Comment 1

17 years ago
Created attachment 73853 [details]
Email causing Mozilla crash

When this email is opened from IMAP folder it crashes Mozilla
(Reporter)

Comment 2

17 years ago
Created attachment 73854 [details]
Second message causing crash
(Reporter)

Updated

17 years ago
Keywords: crash

Comment 3

17 years ago
Stephen, should I ask you for TB3980428G, TB3980387Z, TB3980355W, TB3979507Q?
nsImapMailFolder::NormalEndMsgWriteStream
[d:\builds\seamonkey\mozilla\mailnews\imap\src\nsImapMailFolder.cpp, line 3661]
xptiInterfaceInfoManager::Release
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptinfo\src\xptiInterfaceInfoManager.cpp,
line 46]
nsProxyEventObject::GetNewOrUsedProxy
[d:\builds\seamonkey\mozilla\xpcom\proxy\src\nsProxyEventObject.cpp, line 222]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 582]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 516]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1070] 

Comment 5

17 years ago
Marking as dupe of bug 126987 regarding stack trace signature. Reporter: If you
disagree, please reopen this bug.

*** This bug has been marked as a duplicate of 126987 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Summary: Mozilla crashes when opening certain email messages → Mozilla crashes when opening certain email messages [@ nsImapMailFolder::NormalEndMsgWriteStream]
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Crash Signature: [@ nsImapMailFolder::NormalEndMsgWriteStream]
You need to log in before you can comment on or make changes to this bug.