Move filter action copies the message instead of moving

RESOLVED INVALID

Status

MailNews Core
Filters
RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: Jussi Torhonen, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Move filter copies the filtered message to the target folder and leaves the
original message into Inbox folder. Instead of Move it does Copy function, even
Move was specified for the filter.


Reproducible: Always
Steps to Reproduce:
1. create filter to move some messages into a Ibnox subfolder in basis of To/Cc
address (typical mailing list filter)
2. wait for a mail from the list (or send one to your own address and put
mailing list address into Cc: header field)
3. see the incoming message being copied into the target folder specified in the
filter
4. still found the original message in Inbox folder


Actual Results:  The message was left to Inbox as well as it was copied to the
target folder specified in the filter.


Expected Results:  When using Move filter, the message should first be copied to
the target folder and if succeeding, the message sghould be deleted from the
originating Inbox folder.
(Reporter)

Comment 1

16 years ago
Selected Modern theme instead of that 'Lopburi Flat' used when writing this bug
ID. That seems to help.

Amazing. Installing a non 0.9.9 theme into Mozilla 0.9.9 could break many
things. Check my another report http://bugzilla.mozilla.org/show_bug.cgi?id=130539

Jussi

Comment 2

15 years ago
I think this should be resolved as INVALID because the mentioned problem is
caused by using an incompatible theme.
Mozilla allowing that profile being used can be considered a bug. But that's
another problem, clearly not covered by this bug's description.
See comment #1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.