[non-e10s] Intermittent test_window_management.py TestSwitchWindow.test_windows | ScriptTimeoutException: ScriptTimeoutException: timed out

RESOLVED DUPLICATE of bug 1274948

Status

RESOLVED DUPLICATE of bug 1274948
2 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({intermittent-failure})

Version 3
All
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

+++ This bug was initially created as a clone of Bug #1274948 +++

https://treeherder.mozilla.org/logviewer.html#?job_id=3988677&repo=autoland

21:45:02     INFO -  TEST-START | test_window_management.py TestSwitchWindow.test_windows
21:45:11    ERROR -  TEST-UNEXPECTED-ERROR | test_window_management.py TestSwitchWindow.test_windows | ScriptTimeoutException: Timed out
21:45:11     INFO -  Traceback (most recent call last):
21:45:11     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette_test/testcases.py", line 162, in run
21:45:11     INFO -      testMethod()
21:45:11     INFO -    File "/builds/slave/test/build/tests/marionette/tests/testing/marionette/harness/marionette/tests/unit/test_window_management.py", line 39, in test_windows
21:45:11     INFO -      self.open_new_window()
21:45:11     INFO -    File "/builds/slave/test/build/tests/marionette/tests/testing/marionette/harness/marionette/tests/unit/test_window_management.py", line 22, in open_new_window
21:45:11     INFO -      """)
21:45:11     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 1720, in execute_async_script
21:45:11     INFO -      rv = self._send_message("executeAsyncScript", body, key="value")
21:45:11     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette_driver/decorators.py", line 42, in _
21:45:11     INFO -      return func(*args, **kwargs)
21:45:11     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 693, in _send_message
21:45:11     INFO -      self._handle_error(err)
21:45:11     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 726, in _handle_error
21:45:11     INFO -      raise errors.lookup(error)(message, stacktrace=stacktrace)
21:45:11     INFO -  TEST-INFO took 8911ms
I don't think it makes sense to track this failure twice. If it does not only happen in e10s mode, then lets fix the summary of bug 1274948.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1274948
You need to log in before you can comment on or make changes to this bug.