Closed Bug 1305234 Opened 3 years ago Closed 3 years ago

Crash in gfxASurface::Wrap

Categories

(Core :: Graphics, defect, critical)

50 Branch
All
Windows
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox49 --- unaffected
firefox50 --- fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: philipp, Assigned: eflores)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-37d89dc2-17d2-4737-a3a6-1815f2160924.
=============================================================
Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	xul.dll 	gfxASurface::Wrap(_cairo_surface*, mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const&) 	gfx/thebes/gfxASurface.cpp:174
1 	xul.dll 	gfxWindowsNativeDrawing::BeginNativeDrawing() 	gfx/thebes/gfxWindowsNativeDrawing.cpp:63
2 	xul.dll 	nsNativeThemeWin::DrawWidgetBackground(nsRenderingContext*, nsIFrame*, unsigned char, nsRect const&, nsRect const&) 	widget/windows/nsNativeThemeWin.cpp:1640
3 		@0xb51c4af 	
4 	xul.dll 	gfxContextAutoSaveRestore::Restore() 	obj-firefox/dist/include/gfxContext.h:577
5 	xul.dll 	nsDisplayText::Paint(nsDisplayListBuilder*, nsRenderingContext*) 	layout/generic/nsTextFrame.cpp:4816
6 	xul.dll 	nsDisplayThemedBackground::PaintInternal(nsDisplayListBuilder*, nsRenderingContext*, nsRect const&, nsRect*) 	layout/base/nsDisplayList.cpp:3238
7 	xul.dll 	nsDisplayThemedBackground::Paint(nsDisplayListBuilder*, nsRenderingContext*) 	layout/base/nsDisplayList.cpp:3222
8 	xul.dll 	mozilla::FrameLayerBuilder::PaintItems(nsTArray<mozilla::FrameLayerBuilder::ClippedDisplayItem>&, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&, gfxContext*, nsRenderingContext*, nsDisplayListBuilder*, nsPresContext*, mozilla::gfx::IntPointTyped<mozilla::gfx::UnknownUnits> const&, float, float, int) 	layout/base/FrameLayerBuilder.cpp:5713
9 	xul.dll 	mozilla::FrameLayerBuilder::DrawPaintedLayer(mozilla::layers::PaintedLayer*, gfxContext*, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::layers::DrawRegionClip, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, void*) 	layout/base/FrameLayerBuilder.cpp

crashes with this signature are regressing in number since firefox 50 builds with MOZ_CRASH("Unknown cairo surface type") added in bug 1279398. one user comment says this happened when printing a page.

in early data from 50.0b1 this is the #7 crasher with 1.25% of all browser crashes.
Duplicate of this bug: 1305235
jwatt touched this code in bug 1279398 but he's away until October. eflores r+'d jwatt's patch, so let's ask if him if he has any idea what's going wrong...
Flags: needinfo?(edwin)
Clearly it isn't unused as we had thought. Best course of action is to back out that patch, IMO.
Flags: needinfo?(edwin)
Edwin, could you get us a backout, on nightly, aurora, beta, if we need separate patches, to see if we can make the Thursday beta build.
Flags: needinfo?(edwin)
Attached patch 1305234.patchSplinter Review
Approval Request Comment
[Feature/regressing bug #]: bug 1279398
[User impact if declined]: crashes
[Describe test coverage new/current, TreeHerder]: backout
[Risks and why]: none; original bug was just removing ostensibly dead code
[String/UUID change made/needed]: none
Flags: needinfo?(edwin)
Attachment #8795425 - Flags: review+
Attachment #8795425 - Flags: approval-mozilla-beta?
Attachment #8795425 - Flags: approval-mozilla-aurora?
Applies cleanly on all branches.
Comment on attachment 8795425 [details] [diff] [review]
1305234.patch

Fix for a top crasher on Beta50, let's take it.
Attachment #8795425 - Flags: approval-mozilla-beta?
Attachment #8795425 - Flags: approval-mozilla-beta+
Attachment #8795425 - Flags: approval-mozilla-aurora?
Attachment #8795425 - Flags: approval-mozilla-aurora+
Hi Wes, this is something we should backout before Thursday noon so we can mitigate this crash in 50.0b3. Thanks!
Flags: needinfo?(wkocher)
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/eb9ded2e7fd1
Back out changeset f7aeb4b3ccb1 (bug 1279398) for causing top crashes. r=edwin DONTBUILD
Keywords: checkin-needed
This was merged to m-c, but the bug never got marked.
https://hg.mozilla.org/mozilla-central/rev/eb9ded2e7fd1
Status: NEW → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.