../shinano-common/extract-files.sh: line 68: adb: command not found

RESOLVED INVALID

Status

Firefox OS
Runtime
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Vagrantin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36
(Reporter)

Comment 1

a year ago
mozilla-inboud B2G Device Image opt Aries 



../shinano-common/extract-files.sh: line 68: adb: command not found
/home/worker/workspace/gecko/media/webrtc/trunk/webrtc/modules/video_capture/linux/device_info_linux.cc:408:29: error: aggregate 'webrtc::videocapturemodule::DeviceInfoLinux::FillCapabilities(int)::v4l2_frmsizeenum frmsize' has incomplete type and cannot be defined
/home/worker/workspace/gecko/media/webrtc/trunk/webrtc/modules/video_capture/linux/device_info_linux.cc:409:29: error: aggregate 'webrtc::videocapturemodule::DeviceInfoLinux::FillCapabilities(int)::v4l2_frmivalenum frmival' has incomplete type and cannot be defined
/home/worker/workspace/gecko/media/webrtc/trunk/webrtc/modules/video_capture/linux/device_info_linux.cc:416:26: error: 'VIDIOC_ENUM_FRAMESIZES' was not declared in this scope
/home/worker/workspace/gecko/media/webrtc/trunk/webrtc/modules/video_capture/linux/device_info_linux.cc:417:33: error: 'V4L2_FRMSIZE_TYPE_DISCRETE' was not declared in this scope
/home/worker/workspace/gecko/media/webrtc/trunk/webrtc/modules/video_capture/linux/device_info_linux.cc:422:31: error: 'VIDIOC_ENUM_FRAMEINTERVALS' was not declared in this scope
make[6]: *** [Unified_cpp_webrtc_modules0.o] Error 1
make[5]: *** [media/webrtc/trunk/webrtc/modules/modules_video_capture_module_internal_impl/target] Error 2
make[5]: *** Waiting for unfinished jobs....
make[4]: *** [compile] Error 2
make[3]: *** [default] Error 2
make[2]: *** [realbuild] Error 2
make[1]: *** [build] Error 2
make: *** [out/target/product/aries/obj/DATA/gecko_intermediates/gecko] Error 2
Return code: 2
failed to build
Running post_fatal callback...
Exiting 2

Comment 2

a year ago
The relevant code is here: https://github.com/mozilla-b2g/device-shinano-common/blob/master/extract-files.sh#L68

The script attempts to extract files from a device connected by ADB when it cannot find the backup-${DEVICE}/root/sbin folder.  Presumably this folder needs to be included in the docker image for this build ...
Which docker image? adb is a build prerequisite, we don't ship it.

I'm closing this bug, but feel free to reopen if I misunterstood your issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Comment 4

a year ago
The issue is that Aries builds are failing on taskcluster.  I misread this though -- the titular error message is not the problem, rather it is the subsequent one: 

error: aggregate 'webrtc::videocapturemodule::DeviceInfoLinux::FillCapabilities(int)::v4l2_frmsizeenum frmsize' has incomplete type and cannot be defined.

But this already has a bug, https://bugzilla.mozilla.org/show_bug.cgi?id=1304965
You need to log in before you can comment on or make changes to this bug.