Shift+F2 no longer closes Developer Toolbar in 49.0.1, broken hotkey

VERIFIED FIXED in Firefox 50

Status

DevTools
Graphic Commandline and Toolbar
P1
normal
VERIFIED FIXED
2 years ago
a month ago

People

(Reporter: NoName, Assigned: jlongster)

Tracking

({regression})

49 Branch
Firefox 52
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox49 wontfix, firefox-esr45 unaffected, firefox50+ verified, firefox51+ verified, firefox52+ verified)

Details

(Whiteboard: [reserve-html])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

- Use Firefox Version 49.0.1
- open the Developer Toolbar (Shift+F2)
- try to close the Developer Toolbar by pressing Shift+F2 again


Actual results:

The Developer Toolbar does not close and the hotkey has no function.


Expected results:

The Developer Toolbar should have been toggled when pressing Shift+F2. 
When it's open, it should close, and when it's closed, it should open.
It used to toggle in all the previous versions, but now the only way to close it is by clicking the tiny X with the mouse cursor.

Updated

2 years ago
Status: UNCONFIRMED → NEW
status-firefox49: --- → wontfix
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox-esr45: --- → unaffected
tracking-firefox50: --- → ?
tracking-firefox51: --- → ?
tracking-firefox52: --- → ?
Component: Untriaged → Developer Tools: Graphic Commandline and Toolbar
Ever confirmed: true
Keywords: regression

Comment 1

2 years ago
Regression window: 
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=f4fbac42bc5e86aeb36fb2d4157fa6dbcf4e441e&tochange=be6fddfc1390a14cd560eb843162f0cccd804e63


Regressed by: be6fddfc1390	James Long — Bug 1265854 - replace uses of nsiDOMNode constants in devtools frontend r=tromey
Blocks: 1265854
Flags: needinfo?(jlong)

Updated

2 years ago
Blocks: 1263287
Whiteboard: [devtools-html] [triage]

Comment 2

2 years ago
Error shows Browser Console:
TypeError: nodeConstants is undefined[Learn More]  developer-toolbar.js:400:1
(Assignee)

Updated

2 years ago
Assignee: nobody → jlong
Flags: needinfo?(jlong)
(Assignee)

Comment 3

2 years ago
Created attachment 8795439 [details] [diff] [review]
1305416.patch

Updated

2 years ago
Status: NEW → ASSIGNED
Iteration: --- → 52.1 - Oct 3
Flags: qe-verify+
Priority: -- → P1
QA Contact: cristian.comorasu
Whiteboard: [devtools-html] [triage] → [reserve-html]

Comment 5

2 years ago
Tracked for 50+ since it's a new regression since Fx49.
tracking-firefox50: ? → +
tracking-firefox51: ? → +
tracking-firefox52: ? → +

Comment 6

2 years ago
Pushed by jlong@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/9c71ad1d8a69
fix closing the developer toolbar with keyboard shortcut r=me
(Assignee)

Comment 7

2 years ago
Comment on attachment 8795439 [details] [diff] [review]
1305416.patch

Approval Request Comment
[Feature/regressing bug #]: Bug 1265854
[User impact if declined]: users can't close gcli as expected
[Describe test coverage new/current, TreeHerder]: NA
[Risks and why]: It's an extremely small change that only affects part of the devtools
[String/UUID change made/needed]:
Attachment #8795439 - Flags: approval-mozilla-beta?
Attachment #8795439 - Flags: approval-mozilla-aurora?

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9c71ad1d8a69
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox52: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52

Comment 9

2 years ago
Hello there, could you please verify this issue is fixed as expected on a latest Nightly build (09-30)? Thanks!
Flags: needinfo?(chrimo2)
(Reporter)

Comment 10

2 years ago
(In reply to Ritu Kothari (:ritu) from comment #9)
> Hello there, could you please verify this issue is fixed as expected on a
> latest Nightly build (09-30)? Thanks!

Hello, the issue is fixed as expected on 52.0a1 (2016-09-29) (64-bit), thank you very much!
Comment on attachment 8795439 [details] [diff] [review]
1305416.patch

Fixes a recent regression, Aurora51+, Beta50+
Attachment #8795439 - Flags: approval-mozilla-beta?
Attachment #8795439 - Flags: approval-mozilla-beta+
Attachment #8795439 - Flags: approval-mozilla-aurora?
Attachment #8795439 - Flags: approval-mozilla-aurora+
Hi James, if you tested this fix manually then instead of saying NA in test coverage section of uplift template, please mention that you tested it manually in future. Generally we do not want to uplift any fixes that haven't either been verified manually/externally or via automation. Thanks!
Flags: needinfo?(jlong)

Comment 13

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/090e85a9a698
status-firefox51: affected → fixed

Comment 14

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/330d3ee35628
status-firefox50: affected → fixed
(Assignee)

Comment 15

2 years ago
(In reply to Ritu Kothari (:ritu) from comment #12)
> Hi James, if you tested this fix manually then instead of saying NA in test
> coverage section of uplift template, please mention that you tested it
> manually in future. Generally we do not want to uplift any fixes that
> haven't either been verified manually/externally or via automation. Thanks!

Gotcha, will do, thanks.
Flags: needinfo?(jlong)

Comment 16

2 years ago
I was able to reproduce the issue using Firefox 49.0 RC on Windows 10 Pro x64.

The fix was verified on latest Nightly 52.0a1 (2016-09-29), latest Aurora 51.0a2 (2016-09-30) and Beta 50.0b3 Build 1, across platforms Windows 10 Pro x64, Ubuntu 16.04 LTS x64 and Mac OS Yosemite 10.10.4
I reproduced this bug using Fx 52.0a1, build ID: 20160926030203, on Windows 10 x64.

I can confirm this issue is fixed, I verified using:

 Fx50.0b3 (20160929120120)
 Fx51.0a2 (20160930004005)
 Fx52.0a1 (20160930030315)

On the following platforms:

 Windows 10 x64
 Mac OS X 10.10.5
 Ubuntu 14.04 LTS

Cheers!
Status: RESOLVED → VERIFIED
status-firefox50: fixed → verified
status-firefox51: fixed → verified
status-firefox52: fixed → verified
Flags: qe-verify+
(Reporter)

Updated

2 years ago
Flags: needinfo?(chrimo2)

Updated

2 years ago
Duplicate of this bug: 1313037

Updated

2 years ago
Duplicate of this bug: 1318288

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.