Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Download dialog should automatically select Open with when I change the open application using the dropdown

RESOLVED DUPLICATE of bug 1269956

Status

()

Firefox
File Handling
P3
normal
RESOLVED DUPLICATE of bug 1269956
10 months ago
10 months ago

People

(Reporter: marvenec, Unassigned)

Tracking

({ux-userfeedback})

48 Branch
ux-userfeedback
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160824215626

Steps to reproduce:

When I click on any link that leads to downloading a file, a dialog is opened (depending on the browser configuration of course) that allows me to select which operation I want to perform with the downloaded file.I have two radio buttons allowing me to select either Open with... or Download. The Open with option is followed by a dropdown list of available applications.


Actual results:

When I click on the dropdown list of available applications I can change the application. However, to really use it, I can click once more to select the option Open with (when this is not the default).


Expected results:

Whenever I click on the dropdown list of available applications, I demonstrate my intentions to use some application to open the downloaded file with an application. So I would like the option Open with to be automatically selected whenever I click the dropdown list. For me not to have to click once more on the option. This one extra click is in vain.
(Reporter)

Updated

10 months ago
Keywords: ux-userfeedback
OS: Unspecified → All
Hardware: Unspecified → All

Updated

10 months ago
Component: Untriaged → File Handling

Comment 1

10 months ago
We're implementing new design.
- https://bugzilla.mozilla.org/show_bug.cgi?id=1269956
Sorry for any inconvenience.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Priority: -- → P3
Resolution: --- → DUPLICATE
Duplicate of bug: 1269956
You need to log in before you can comment on or make changes to this bug.