When opening devtools inspector, "Chrome file doesn't exist: ...dist/bin/browser/chrome/devtools/content/inspector/markup/markup.css" (and similar for codemirror's dialog.css)

RESOLVED DUPLICATE of bug 1305568

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 1305568
a year ago
a year ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
STR:
 1. Start up a Firefox debug build from the terminal. (./mach run)
 2. Press F12 and then click "Inspector".
    (Or Ctrl+Shift+C or Tools|Web Developer|Inspector)
 3. Look at your terminal.

ACTUAL RESULTS:
I see this logging, indicating that we're referencing some nonexistent stylesheets via chrome:// URIs:
{
Chrome file doesn't exist: /scratch/work/builds/mozilla-inbound/obj/dist/bin/browser/chrome/devtools/content/inspector/markup/markup.css
Chrome file doesn't exist: /scratch/work/builds/mozilla-inbound/obj/dist/bin/browser/chrome/devtools/content/sourceeditor/codemirror/addon/dialog/dialog.css
Chrome file doesn't exist: /scratch/work/builds/mozilla-inbound/obj/dist/bin/browser/chrome/devtools/content/sourceeditor/codemirror/addon/dialog/dialog.css
}

EXPECTED RESULTS:
No such logging. (We should remove/correct the bogus stylesheet URIs.)


I suspect this might be involved with causing bug 1304197 (some spammy logging about stylesheets not being found during devtools tests), though I'm not sure.
Comment hidden (offtopic)
Comment hidden (offtopic)
(Reporter)

Comment 3

a year ago
NOTES FROM SOME DXR SEARCHES:

The first error (for markup.css) seems to probably come from this chunk of source:
>  <link rel="stylesheet" href="chrome://devtools/content/inspector/markup/markup.css" type="text/css"/>
>  <link rel="stylesheet" href="chrome://devtools/skin/markup.css" type="text/css"/>
https://dxr.mozilla.org/mozilla-central/rev/29beaebdfaccbdaeb4c1ee5a43a9795ab015ef49/devtools/client/inspector/markup/markup.xhtml#10

If I try viewing those chrome:// URIs directly (in my debug build or in my Nightly build), the first one gives me "file not found".  The latter one is fine.


The latter two errors (for dialog.css) seem to probably come from the middle line here:
> const CM_STYLES = [
>   "chrome://devtools/content/sourceeditor/codemirror/lib/codemirror.css",
>   "chrome://devtools/content/sourceeditor/codemirror/addon/dialog/dialog.css",
>   "chrome://devtools/content/sourceeditor/codemirror/mozilla.css"
> ];
https://dxr.mozilla.org/mozilla-central/rev/29beaebdfaccbdaeb4c1ee5a43a9795ab015ef49/devtools/client/sourceeditor/editor.js#47

...and this link tag here:
>     <link rel="stylesheet"
>           type="text/css"
>           href="chrome://devtools/content/sourceeditor/codemirror/addon/dialog/dialog.css" />
https://dxr.mozilla.org/mozilla-central/rev/29beaebdfaccbdaeb4c1ee5a43a9795ab015ef49/devtools/client/debugger/new/index.html#10

This one's a bit different -- the chrome:// URI resolves just fine in my Nightly build, but it gives me "File not found" in my debug build.
(Reporter)

Updated

a year ago
Summary: When opening devtools inspector, "Chrome file doesn't exist: ...dist/bin/browser/chrome/devtools/content/inspector/markup/markup.css" → When opening devtools inspector, "Chrome file doesn't exist: ...dist/bin/browser/chrome/devtools/content/inspector/markup/markup.css" (and similar for codemirror's dialog.css)
(Reporter)

Comment 4

a year ago
James, it looks like you added the latter chunk quoted in comment 3, very recently (in https://hg.mozilla.org/mozilla-central/rev/0b15e1201105 ) -- any chance you could look into whether these stylesheet URLs should be corrected vs. removed?

This would be nice from the perspective of fixing the spam quoted in comment 0 -- and also, it might address a particularly-bad source of logspam (bug 1304197).  (Or, if it doesn't end up addressing that logspam, it'll at least be useful to rule this out as the cause.)
Blocks: 1304197
Flags: needinfo?(jlong)
This URLs should be correct, I'm not sure why they wouldn't exist. As you said, it works fine in a non-debug build, I have no idea why it doesn't work in a debug build... Maybe bgrins knows?
Flags: needinfo?(jlong) → needinfo?(bgrinstead)
(Reporter)

Comment 6

a year ago
(In reply to James Long (:jlongster) from comment #5)
> As you said, it works fine in a non-debug build

Only the second URL (the one that you added) -- the first one (chrome://devtools/content/inspector/markup/markup.css ) doesn't work in any type of build, AFAICT.

(Maybe I should have filed two separate bugs for these two URLs -- I grouped them here since they're all spammed at once and might [together] be the cause of bug 1304197. Let me know if you'd prefer I fork this into two bugs.)
So, the reference to chrome://devtools/content/inspector/markup/markup.css should just be removed.  All markups styles are now loaded from devtools/client/themes/markup.css aka chrome://devtools/skin/markup.css.  I'll file another bug for that
See Also: → bug 1305568
I've just tested in a clean debug build from fx-team of chrome://devtools/content/sourceeditor/codemirror/addon/dialog/dialog.css, and it's loading for me.  I used an artifact build, but I'm assuming that shouldn't matter.

Can you check and see if this is still a problem for you in a clean profile and/or with a clobber?
Flags: needinfo?(bgrinstead) → needinfo?(dholbert)
(Reporter)

Comment 9

a year ago
Thanks -- yeah, I'm only seeing the first error now. (for markup.css)

Not sure what was going on with the dialog.css error or why it became fixed -- I think I pulled & rebuilt since having filed this bug, so it's possible it was fixed by some commit, or perhaps by clearing some busted state in my objdir and/or my temporary "./mach run" profile.  Sorry for the false alarm -- I'll let you know if I see this again for "dialog.css", though.

So I guess the only remaining issue here is the issue that bgrins is fixing in bug 1305476 -- so we should probably dupe that bug & this one, one way or the other.  bgrins, I'll let you sort that out however you see fit. (I won't be offended if it's easier to just dupe this forward to bug 1305476 :))
Flags: needinfo?(dholbert) → needinfo?(bgrinstead)
OK, going to just dupe this to 1305476 since there's a patch attached already there.  Thanks for filing
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(bgrinstead)
Resolution: --- → DUPLICATE
Duplicate of bug: 1305568
(Reporter)

Updated

a year ago
No longer blocks: 1304197
You need to log in before you can comment on or make changes to this bug.