Open Bug 1305524 Opened 3 years ago Updated 3 months ago

./mach run to run the fennec emulator build doesn't work on OS X

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

51 Branch
defect
Not set

Tracking

(Not tracked)

People

(Reporter: kats, Unassigned)

References

Details

Attachments

(1 file)

Attached file Mach run output
My mozconfig is at [1]. On an OS X machine, I did a ./mach build && ./mach package followed by a ./mach run. This used to work but now it fails. See attachment for the output when I try to run.

[1] https://github.com/staktrace/moz-scripts/blob/master/mozconfig.Darwin-android-ndebug
It seems to be complaining about the line at [1] which was last touched by jgriffin. Any thoughts?

[1] http://searchfox.org/mozilla-central/rev/05ed82e50b45df5aa5a8fad219dece1b56757261/testing/mozbase/mozprofile/mozprofile/permissions.py#17
Flags: needinfo?(jgriffin)
I re-ran ./mach bootstrap and after working around bug 1280165 I'm doing a clobber build, let's see if that behaves better.
Still getting the same error after a clobbered bootstrapped build.
Seems like a library problem; see e.g., http://stackoverflow.com/questions/14817507/os-x-10-8-2-python-3-import-sqlite-error
Flags: needinfo?(jgriffin)
I tried the things suggested in that post but none of them worked. I still consider this a Firefox build system bug since bootstrap should install everything needed.
I managed to get this working after updating the xcode CLT and uninstalling/reinstalling python from homebrew.
Product: Firefox for Android → Firefox Build System
You need to log in before you can comment on or make changes to this bug.