Closed Bug 1305602 Opened 6 years ago Closed 5 years ago

Intermittent gmake[5]: *** [.gradle.deps] Error 1 | gmake[4]: *** [mobile/android/base/libs] Error 2 due to "Failed to apply plugin [id 'android-sdk-manager'] error"

Categories

(Taskcluster :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: philor, Assigned: nalexander)

References

Details

(Keywords: intermittent-failure)

+++ This bug was initially created as a clone of Bug #1292762 +++

https://treeherder.mozilla.org/logviewer.html#?job_id=4035760&repo=autoland

 02:14:42     INFO -  FAILURE: Build failed with an exception.
 02:14:42     INFO -  * Where:
 02:14:42     INFO -  Build file '/home/worker/workspace/build/src/mobile/android/app/build.gradle' line: 3
 02:14:42     INFO -  * What went wrong:
 02:14:42     INFO -  A problem occurred evaluating project ':app'.
 02:14:42     INFO -  > Failed to apply plugin [id 'android-sdk-manager']
 02:14:42     INFO -     > Specified SDK directory '/home/worker/.android-sdk' in 'local.properties' is not found.
 02:14:42     INFO -  * Try:
 02:14:42     INFO -  Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
 02:14:42     INFO -  BUILD FAILED
 02:14:42     INFO -  Total time: 18.722 secs
 02:14:43     INFO -  gmake[5]: *** [.gradle.deps] Error 1
 02:14:43     INFO -  gmake[5]: *** Deleting file `.gradle.deps'
 02:14:43     INFO -  gmake[5]: Leaving directory `/home/worker/workspace/build/src/obj-firefox/mobile/android/base'
 02:14:43     INFO -  gmake[4]: *** [mobile/android/base/libs] Error 2
 02:14:43     INFO -  gmake[4]: Leaving directory `/home/worker/workspace/build/src/obj-firefox'
 02:14:43     INFO -  gmake[3]: *** [libs] Error 2
 02:14:43     INFO -  gmake[3]: Leaving directory `/home/worker/workspace/build/src/obj-firefox'
 02:14:43     INFO -  gmake[2]: *** [default] Error 2
 02:14:43     INFO -  gmake[2]: Leaving directory `/home/worker/workspace/build/src/obj-firefox'
 02:14:43     INFO -  gmake[1]: *** [realbuild] Error 2
 02:14:43     INFO -  gmake[1]: Leaving directory `/home/worker/workspace/build/src'
 02:14:43     INFO -  gmake: *** [build] Error 2
 02:14:43     INFO -  0 compiler warnings present.
 02:14:43    ERROR - Return code: 2
 02:14:43  WARNING - setting return code to 2
 02:14:43    FATAL - 'mach build' did not run successfully. Please check log for errors.
 02:14:43    FATAL - Running post_fatal callback...
 02:14:43    FATAL - Exiting -1
Thanks for filing, philor.  Looks like a similar cause as Bug 1292762, but a different resolution will be needed.  That ticket was a real build; we solved the problem by ensuring the android-sdk-manager plugin didn't run by forcing everything offline.  This is a deps build; by design it must run online.  I'll figure out how to make that directory really exist for the plugin; I think this might be a filesystem/mkdir race of some sort.
Assignee: nobody → nalexander
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.