Bug in adaptive design

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Responsive Design Mode
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: devlev, Unassigned)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(firefox49 affected, firefox50 affected, firefox51 affected, firefox52 affected)

Details

(Whiteboard: [specification][type:bug])

(Reporter)

Description

a year ago
What did you do?
================
1. I open web site
2. Ctrl + Shift + M


What happened?
==============
No view adaptive disign

What should have happened?
==========================
View online mobile scroll but not view menu adaptive disign

Is there anything else we should know?
======================================
Version Firefox 49.0.1
Do you have this problem just on https://developer.mozilla.org/en-US/ or on all websites?
Flags: needinfo?(rurlevv)
(Reporter)

Comment 2

a year ago
I have this problem from all websites.
Screenshot's
http://f6.s.qip.ru/oHGounjD.png
http://f6.s.qip.ru/oHGounjE.png
Now my brouser no view menu http://f4.s.qip.ru/oHGounjF.png
http://f3.s.qip.ru/oHGounjG.png
http://f1.s.qip.ru/oHGounjH.png
Component: User management → Untriaged
Product: Mozilla Developer Network → Firefox
Hi Devlev,

I tested this issue on Windows 10 x64 with FF versions: 52, 51, 50, 49 and I can reproduce this issue. Please note that from 980 x 1280 resolution up I can't reproduce this issue. The issue is reproducible with resolutions smaller than 980 x 1280. For the test I used the www.google.com site.
Status: UNCONFIRMED → NEW
status-firefox49: --- → affected
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
Component: Untriaged → Developer Tools: Responsive Design Mode
Ever confirmed: true
Version: unspecified → Trunk
:Ovidiu, it seems like you were able to confirm this issue?  Can you provide more detailed steps to reproduce?  If I for example open Responsive Design Mode in 49 on google.com, I _do_ get the expected UI with a size menu, and when I close RDM, there is only a horizontal scrollbar, not a vertical one.
Flags: needinfo?(ovidiu.boca)
Hi Ryan,

Here is what I did:

1. Go to www.google.com
2. From the Tools -> Web Developer -> Responsive Design Mode
3. I started to change the resolutions one by one. 

I notice that when you choose resolutions smaller than 980 x 1280 the page is not centered. I compared with Chrome and there the page is centered. I Think this is the expected result in this case, after you change the resolution the page to remain centered.
Flags: needinfo?(ovidiu.boca)
(In reply to ovidiu boca[:Ovidiu] from comment #5)
> Hi Ryan,
> 
> Here is what I did:
> 
> 1. Go to www.google.com
> 2. From the Tools -> Web Developer -> Responsive Design Mode
> 3. I started to change the resolutions one by one. 
> 
> I notice that when you choose resolutions smaller than 980 x 1280 the page
> is not centered. I compared with Chrome and there the page is centered. I
> Think this is the expected result in this case, after you change the
> resolution the page to remain centered.

Okay, this part seems "expected", google.com doesn't not seem to send a responsive page by default.  In Chrome Canary, if the "device type" is set to Mobile, the content is centered because they send a mobile user agent which returns different page content.  The current RDM doesn't offer this feature at the moment.
devlev, could you explain the problem in a bit more detail?

It sounds like you are saying:

1. You press Ctrl + Shift + M
2. You are expecting to see the Responsive Design Mode UI (with resolution menu, etc.) but it doesn't appear
3. You are seeing scrollbars that you do not expect even though RDM UI is closed

Is that correct?
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #6)

> 
> Okay, this part seems "expected", google.com doesn't not seem to send a
> responsive page by default.  In Chrome Canary, if the "device type" is set
> to Mobile, the content is centered because they send a mobile user agent
> which returns different page content.  The current RDM doesn't offer this
> feature at the moment.

Thanks Ryan for clearing this out, let's see what Devlev has to say about comment 7. Please note that in my case I can see the Responsive Design Mode UI (with resolution menu, etc.).
(Reporter)

Comment 9

a year ago
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #7)
> devlev, could you explain the problem in a bit more detail?
> 
> It sounds like you are saying:
> 
> 1. You press Ctrl + Shift + M
> 2. You are expecting to see the Responsive Design Mode UI (with resolution
> menu, etc.) but it doesn't appear
> 3. You are seeing scrollbars that you do not expect even though RDM UI is
> closed
> 
> Is that correct?

I often use adaptive design
Everything was fine
One day, I turn on the adaptive design and do not see a menu with a choice of resolution and the ability to change the size of an internal window
In the transition to adaptive design I have changed just scroll
This I have shown in the screenshot
And when I worked responsive design pressing keys CTRL + SHIFT + M switched on and off adaptive design
But now adaptive design on and no off!
A small scroll no close, when I click a second click CTRL + SHIFT + M.

I use firefox in work and home computer and all fersion 49.0.1.
Home firefox work is good adaptive design.
At work firefox work is bad adaptive design.

I tried to disable all plug-ins, it did not help.
Hopefully clearly I explained and sorry for my english
Hi Devlev,

I saw that you disabled all your plug-ins, but what about add-ons, did you tested with add-ons disabled? 
Please test if the issue can be reproduced in the safe mode of Firefox: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode.

Based on the fact that your home Firefox is good and your office Firefox is bad, I think there is something with your Firefox profile from the office. Please see what results you get if you try to test this in safe mode.
(Reporter)

Comment 11

a year ago
(In reply to ovidiu boca[:Ovidiu] from comment #10)
> Hi Devlev,
> 
> I saw that you disabled all your plug-ins, but what about add-ons, did you
> tested with add-ons disabled? 
> Please test if the issue can be reproduced in the safe mode of Firefox:
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode.
> 
> Based on the fact that your home Firefox is good and your office Firefox is
> bad, I think there is something with your Firefox profile from the office.
> Please see what results you get if you try to test this in safe mode.

I restart in the safe mode of Firefox.
Problem still exists.

So far, for me, this problem does not cause too much discomfort.
Previously stable time in half a year doing a backup browser via MozBackup
Deletes browser with the profile
I install the latest version from the website
And upload the stored data from MozBackup
Now it seems to be done again predetsya
devlev, after attempting to open Responsive Design Mode in the Firefox where you see the problem, can you check the Browser Console[1] for any errors?  See the MDN page on how to open the Browser Console.

If you see any errors, please paste them as a comment or attachment to this bug.

[1]: https://developer.mozilla.org/en-US/docs/Tools/Browser_Console
(Reporter)

Comment 13

a year ago
Browser Console no show errors.
(In reply to devlev from comment #11)
> So far, for me, this problem does not cause too much discomfort.
> Previously stable time in half a year doing a backup browser via MozBackup
> Deletes browser with the profile
> I install the latest version from the website
> And upload the stored data from MozBackup
> Now it seems to be done again predetsya

When you installed the latest version, but _before_ restoring anything with MozBackup, is it working correctly?
(Reporter)

Comment 15

a year ago
I did a thorough cleaning firefox and it helped me. (Worn additions but for me it is not a problem)
(In reply to devlev from comment #15)
> I did a thorough cleaning firefox and it helped me. (Worn additions but for
> me it is not a problem)

Okay, that's great to hear!  It sounds like this issue is fixed now.  Please reopen if you see this issue again.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(rurlevv)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.