Allow build for aarch64 without system libffi

RESOLVED FIXED in Firefox 52

Status

()

Core
Build Config
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

Trunk
mozilla52
ARM
Linux
Points:
---

Firefox Tracking Flags

(firefox52 fixed)

Details

MozReview Requests

()

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Assignee)

Description

a year ago
After bug 1262155, system libffi is required on aarch64.  But I remove this requirement to support android/aarch64.
Comment hidden (mozreview-request)

Comment 2

a year ago
mozreview-review
Comment on attachment 8795232 [details]
Bug 1305677 - Remove requirement of libffi on aarch64 as default.

https://reviewboard.mozilla.org/r/81342/#review80364

Looks good to me, thank you for the patch.
Attachment #8795232 - Flags: review+

Comment 3

a year ago
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/c419c4807be6
Remove requirement of libffi on aarch64 as default. r=chmanchester

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c419c4807be6
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox52: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Attachment #8795232 - Flags: review?(ted)
You need to log in before you can comment on or make changes to this bug.