Privacy & Security preference tab won't open

VERIFIED DUPLICATE of bug 136040

Status

SeaMonkey
Preferences
--
major
VERIFIED DUPLICATE of bug 136040
17 years ago
13 years ago

People

(Reporter: David W Noon, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031114

After editing the preferences once, the Privacy & Security tab will no longer
expand, either by clicking on the arrowhead next to the text or by
double-clicking on the text itself. The arrowhead rotates as if the detailed
list of preferences were about to drop down, but that is all that happens.

I had no problem the first time I ran this build of the browser, but am now
unable to edit these preferences.

This problem did not occur under 0.9.8.

Reproducible: Always
Steps to Reproduce:
1. Install Warpzilla 0.9.9 into an empty directory.
2. Edit preferences, including Privacy & Security.
3. Shut down browser.
4. Restart browser.
5. Edit preferences, including Privacy & Security.

Actual Results:  The Privacy & Security tab would not expand into the detailed
entries.

This means, of course, that I cannot remove cookies in the normal manner.

Expected Results:  There should be a list of detailed preferences for cookies, etc.

OS/2 Warp 4 fixpak 12
-> Preferences
Assignee: asa → sgehani
Component: Browser-General → Preferences
QA Contact: doronr → sairuh

Comment 2

17 years ago
Are you saying the plus sign doesn't do anything?

What about double clicking on Privacy And Security?

Comment 3

17 years ago
I got a note from the reporter. This happened after a crash. They reinstalled 
and it is fine.

They are opening a separate bug on the crash.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

16 years ago
This problem has just recurred with build 2002041811. The browser has not
crashed, but I cannot get the Privacy & Security tab to drop down the detailed
items, either by clicking on the triangle (or plus sign), or by double clicking
on the line.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

16 years ago
Do you have mail and news icons on the taskbar or have they disappeared?

Please check the overlays.rdf files under the chrome directory and tell me if 
any are empty (you have to display them, it doesn't affect their size)
(Reporter)

Comment 6

16 years ago
There are no icons for mail or news, nor can I find any menu items to start mail
or news sessions.

The overlays.rdf file for communicator is empty. The same-named files for
messenger, editor, inspector and navigator all contain XML source.

Comment 7

16 years ago
We're trying to diagnose this problem which is why I am asking so many 
questions.

Could you try this.

Delete chrome.rdf in the chrome dir and restart mozilla. It should generate all 
new overlays.rdf files.

Then close Mozilla and mark all the overlays.rdf files readonly.

Then let's see if the problem happens again.

We are trying to determine who corrupts the overlays.rdf files, Mozilla or the 
operating system.

Thanks for any help you can provide in looking at this problem.

Comment 8

16 years ago
 This also happens under SOlaris 8. It works once after chrome.rdf is deleted and then 
does not work. I am unable to even find an overlays.rdf file anywhere? 
 
Chris 

Comment 9

16 years ago
 OK. If I delete chrome.rdf in mozilla/chrome, then make mozilla/chrome and everything 
underneath it read only, I get the expected behavior. Makes little sense, but it does 
appear to work. 
(Reporter)

Comment 10

16 years ago
I have deleted chrome.rdf, started and shut down Mozilla, and marked all 5
overlays.rdf files as read-only.

The Privacy & Security tabs now appear, and they have remained workable for a
couple of minutes.

I will report again if it goes all pear shaped once more, or if the interface
holds up for a couple of days.

Comment 11

16 years ago
I had the same problem with my 2002041811, which I installed yesterday.

Deleting bin\chrome\chrome.rdf did _not_ regenerate the .rdf files.
bin\chrome\overlayinfo\communicator\content\overlays.rdf has a file length
greater zero, but only contains NULL.

I tried something different that works as a workaround. I backed up my entire
mozilla directory, deleted it, re-installed Mozilla and re-migrated my profile
from the installed NS 4.61.

This gave me a fresh start on Mozilla and everything looked fine again. Now I
backed up the bin\chrome\overlayinfo tree and deleted the newly installed
Mozilla. I restored my damaged Mozilla. Then I copied
bin\chrome\overlayinfo\communicator\content\overlays.rdf from the fresh install
over to my damaged Mozilla.

That's all.

This fixes four bugs at the same time:
a) The disappeared mail, news etc. icons from the task bar are back
b) The disappeared "block images from this server" context dialogue is back
c) Edit | Preferences | Privacy & Security can once again be expanded
d) Edit | Preferences | Offline & Disk Space is back there again.

So maybe you'd like to combine those bugs.

Question remains, why is this rdf being overwritten?
(Reporter)

Comment 12

16 years ago
Since setting the various overlays.rdf files to read-only, I find that I cannot
make a persistent change to the "skin" in use. When I switch from Classic to
Modern and then re-start Mozilla, the change takes effect. After I reboot the
system, the skin reverts to Classic.

I don't know if this phenomenon is a consequence of the change, but they seem to
be correleated.

Comment 13

16 years ago
You guys can take a look at:

http://bugzilla.mozilla.org/show_bug.cgi?id=136040

For some more info.

We're not sure Mozilla is the one overwriting the file...

Comment 14

16 years ago
These symptoms seen in Solaris are covered in bug 125489.  For Solaris and Linux
this should be fixed in RC1 and recent nightlies.  I have no cluse about OS/2.

Comment 15

16 years ago

*** This bug has been marked as a duplicate of 136040 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.