Scope named windows by their TabGroup

RESOLVED DUPLICATE of bug 1303196

Status

()

P2
normal
RESOLVED DUPLICATE of bug 1303196
2 years ago
2 years ago

People

(Reporter: Nika, Assigned: Nika)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
Right we allow any window to window.open into a common named window. To my understanding, this can allow a window to change TabGroups as it is possible for two TabGroups to become connected through a call to window.open.

We should make named windows be scoped based on the originating TabGroup.
Priority: -- → P2
(Assignee)

Comment 1

2 years ago
The patch I'm working on for bug 1303196 will do this, so I'm assigning this to myself.
Assignee: nobody → michael
(Assignee)

Comment 2

2 years ago
The patch is now up in bug 1303196, so I'm marking this as duplicate.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1303196
You need to log in before you can comment on or make changes to this bug.